Bug 33628 - LayoutTests/storage/quota-tracking.html needs to be cleaned up
: LayoutTests/storage/quota-tracking.html needs to be cleaned up
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: New Bugs
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Dumitru Daniliuc
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-13 15:40 PST by Dumitru Daniliuc
Modified: 2010-01-13 16:22 PST (History)
2 users (show)

See Also:


Attachments
patch (2.60 KB, patch)
2010-01-13 16:04 PST, Dumitru Daniliuc
dglazkov: review+
dumi: commit‑queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dumitru Daniliuc 2010-01-13 15:40:48 PST
Things that need to be cleaned up in quota-tracking.html:
-- Remove all trailing whitespaces
-- Refactor errorFunction(). Right now, it takes two parameters (tx, error) and is used as the error function for both executeSql() and transaction(). The problem is that transaction()'s error callback uses only one parameter. So if a transaction fails, the error gets assigned to the 'tx' parameter, and the 'error' parameter is left undefined; this leads to an exception when errorFunction() tries to log 'error.message'.
Comment 1 Dumitru Daniliuc 2010-01-13 16:04:10 PST
Created attachment 46520 [details]
patch
Comment 2 Dimitri Glazkov (Google) 2010-01-13 16:09:15 PST
Comment on attachment 46520 [details]
patch

LG, except:


> +        Cleaning up quota-tracking.html.

This could use a bit more description.
Comment 3 Dumitru Daniliuc 2010-01-13 16:09:56 PST
(In reply to comment #2)
> (From update of attachment 46520 [details])
> LG, except:
> 
> 
> > +        Cleaning up quota-tracking.html.
> 
> This could use a bit more description.

Will add more details before landing.
Comment 4 Dumitru Daniliuc 2010-01-13 16:22:46 PST
Landed as r53214.