Bug 33094 - List item doesn't show when css is 'height: 0; overflow: visible;'
: List item doesn't show when css is 'height: 0; overflow: visible;'
Status: RESOLVED DUPLICATE of bug 78726
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 528+ (Nightly build)
: PC Windows Vista
: P2 Minor
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-01 07:19 PST by Jorn van Engelen
Modified: 2012-02-16 11:47 PST (History)
2 users (show)

See Also:


Attachments
Testcase and workaround (887 bytes, text/html)
2010-01-01 07:19 PST, Jorn van Engelen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorn van Engelen 2010-01-01 07:19:32 PST
Created attachment 45732 [details]
Testcase and workaround

Browsers tested:
       Safari: FAIL (version 4.0.4, help box reports WebKit version 531.21.10)
Google Chrome: FAIL (version 4.0.249.43)
      Firefox: OK (version 3.5.6)
        Opera: OK (version 10.10 build 4742)


What steps will reproduce the problem?
Open attachment in a WebKit browser.


What is the expected result?
The second box should display the text 'li'.
Notice that the height of the li element is set to 0, but it should still display the content of the element because overflow is set to visible (style attribute on li element is "height: 0; overflow: visible;").


What happens instead?
Second box doesn't display the text 'li'.
Comment 1 Robert Hogan 2012-02-16 11:47:06 PST
Posted a patch at bug 78726 without realizing this was here.

*** This bug has been marked as a duplicate of bug 78726 ***