Bug 32766 - Vim color schemes only partially render (over 200 frames on a page)
Summary: Vim color schemes only partially render (over 200 frames on a page)
Status: RESOLVED DUPLICATE of bug 39427
Alias: None
Product: WebKit
Classification: Unclassified
Component: Frames (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://code.google.com/p/vimcolorsche...
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-18 20:16 PST by mooneer
Modified: 2010-05-20 14:07 PDT (History)
2 users (show)

See Also:


Attachments
Results of rendering vim sample (55.47 KB, image/png)
2009-12-18 20:17 PST, mooneer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mooneer 2009-12-18 20:16:33 PST
When going to the URL and clicking on one of the languages at the bottom of the page for the first time in the browsing session, only half of the samples render (the other half remain empty). Reloading causes none of the samples to render until WebKit's restarted. See attachment for more info.
Comment 1 mooneer 2009-12-18 20:17:36 PST
Created attachment 45221 [details]
Results of rendering vim sample
Comment 2 Alexey Proskuryakov 2009-12-20 13:27:52 PST
This page puts each sample into its own frame. We only allow up to 200 frames on a page, and always have: <http://trac.webkit.org/changeset/3707>.

> Reloading causes none of the samples to
> render until WebKit's restarted. See attachment for more info.

I cannot reproduce this part of the problem.
Comment 3 mooneer 2009-12-20 15:14:45 PST
More info: if you reload the page, the first 200 frames still render. However, if you go view another language, the frames for that other language do not render.

Also, I'm using r52426.
Comment 4 Jeremy Orlow 2010-05-20 14:07:17 PDT

*** This bug has been marked as a duplicate of bug 39427 ***