Bug 32414 - css2 :first-letter applied to joined text not working properly
Summary: css2 :first-letter applied to joined text not working properly
Status: RESOLVED DUPLICATE of bug 47213
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P3 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-11 03:56 PST by Petri Ojala
Modified: 2011-01-20 17:48 PST (History)
4 users (show)

See Also:


Attachments
screenshot (24.57 KB, image/jpeg)
2009-12-11 03:57 PST, Petri Ojala
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petri Ojala 2009-12-11 03:56:33 PST
1. Load the url:
http://www.w3.org/Style/CSS/Test/CSS2.1/current/html4/bidi-first-letter-001.htm
Verify the output

Actual Result: css style not applied to the first character of compound letter

Expected Result: The rightmost half of the rightmost compound on the first line
below should be blue. Except for color the two lines below should be identical.


Note: attached is the screenshot for reference
Comment 1 Petri Ojala 2009-12-11 03:57:48 PST
Created attachment 44664 [details]
screenshot
Comment 2 Jocelyn Turcotte 2010-03-16 08:34:39 PDT
Reproduced on Windows with arora and chrome. Firefox loads the page correctly.
Comment 3 Alexey Proskuryakov 2010-03-16 14:41:07 PDT
Duplicate of bug 6148?

This bug has a Qt keyword, but Mac behaves in the same way.
Comment 4 Yael 2011-01-20 17:48:34 PST

*** This bug has been marked as a duplicate of bug 47213 ***