Bug 32083 - REGRESSION(51595): commit-queue is throwing exceptions
Summary: REGRESSION(51595): commit-queue is throwing exceptions
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 32101 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-02 12:45 PST by Eric Seidel (no email)
Modified: 2009-12-02 21:32 PST (History)
3 users (show)

See Also:


Attachments
Patch (6.00 KB, patch)
2009-12-02 12:57 PST, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff
Better patch (9.07 KB, patch)
2009-12-02 14:19 PST, Eric Seidel (no email)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2009-12-02 12:45:53 PST
REGRESSION(51595): commit-queue is throwing exceptions

More fallout from mixing ints and strings.  Adding more unit tests should prevent this trouble in the future.
Comment 1 Eric Seidel (no email) 2009-12-02 12:57:36 PST
Created attachment 44175 [details]
Patch
Comment 2 Eric Seidel (no email) 2009-12-02 13:07:02 PST
Comment on attachment 44175 [details]
Patch

I'm running the cq with a locally fixed copy, so it's running now and it is possible to cq this patch.
Comment 3 Eric Seidel (no email) 2009-12-02 14:19:20 PST
Created attachment 44185 [details]
Better patch
Comment 4 Eric Seidel (no email) 2009-12-02 15:33:49 PST
This is responsible for the death of the style elf as well I'm sure. :(
Comment 5 WebKit Review Bot 2009-12-02 21:12:07 PST
style-queue ran check-webkit-style on attachment 44185 [details] without any errors.
Comment 6 Adam Barth 2009-12-02 21:19:00 PST
*** Bug 32101 has been marked as a duplicate of this bug. ***
Comment 7 Adam Barth 2009-12-02 21:19:39 PST
Comment on attachment 44185 [details]
Better patch

You win the prize.  Your version of this patch >> my version.
Comment 8 WebKit Commit Bot 2009-12-02 21:31:56 PST
Comment on attachment 44185 [details]
Better patch

Clearing flags on attachment: 44185

Committed r51622: <http://trac.webkit.org/changeset/51622>
Comment 9 WebKit Commit Bot 2009-12-02 21:32:01 PST
All reviewed patches have been landed.  Closing bug.