Bug 32040 - Need to do size, type and stride checking for texImage2D and texSubImage2D
Summary: Need to do size, type and stride checking for texImage2D and texSubImage2D
Status: RESOLVED DUPLICATE of bug 40398
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: All OS X 10.5
: P2 Normal
Assignee: Kenneth Russell
URL:
Keywords:
Depends on: 31562
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-01 16:49 PST by Chris Marrin
Modified: 2010-08-23 13:57 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Marrin 2009-12-01 16:49:46 PST
Currently no checking is done to make sure the passed buffer is large enough for the passed sizes or that the pixelStore params are valid for the passed data. Also need to validate the type, format and internal format for the passed buffer type.
Comment 1 Kenneth Russell 2010-08-23 13:57:01 PDT
This was necessarily fixed as part of https://bugs.webkit.org/show_bug.cgi?id=40398 . Closing as a duplicate.

*** This bug has been marked as a duplicate of bug 40398 ***