Bug 31305 - http/tests/security/mixedContent/redirect-https-to-http-script-in-iframe.html failed on Leopard Commit Bot
Summary: http/tests/security/mixedContent/redirect-https-to-http-script-in-iframe.html...
Status: RESOLVED DUPLICATE of bug 31200
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-10 10:56 PST by Eric Seidel (no email)
Modified: 2009-11-10 16:05 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2009-11-10 10:56:02 PST
http/tests/security/mixedContent/redirect-https-to-http-script-in-iframe.html failed on Leopard Commit Bot

https://bugs.webkit.org/show_bug.cgi?id=29972#c28
and
https://bugs.webkit.org/show_bug.cgi?id=31301#c6

I believe the test is flakey.  CCing author and reviewer.
Comment 1 Eric Seidel (no email) 2009-11-10 11:32:00 PST
Actually, both of these seem to be "real" failures caused by those patches.  I'm just not sure why those patches would cause these failures.  They seem unrelated to this test.
Comment 2 Yael 2009-11-10 15:15:22 PST
The test is failing due to bad SSL certificate. It is not clear to me why my patch at https://bugs.webkit.org/show_bug.cgi?id=29972 is triggering this failure.

In fact, if you run each of the tests at LayoutTests/http/tests/security/mixedContent one by one, they all fail for this reason.
Comment 3 Eric Seidel (no email) 2009-11-10 16:02:21 PST

*** This bug has been marked as a duplicate of bug 31200 ***