Bug 30532 - [Gtk] Wrong font size calculated on google.com
Summary: [Gtk] Wrong font size calculated on google.com
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL: http://www.google.com/
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2009-10-19 13:44 PDT by Jason Clinton
Modified: 2010-12-29 23:35 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Clinton 2009-10-19 13:44:09 PDT
Some pages have different font sizes than are expected. For example, go to Google's home page, right click "Advertising Programs", click Inspect Element. Click Computed Style -> Show Inherited. In Epiphany/Webkit font-size value is 15px. In Google Chrome, it's 13px. Firefox agrees with Chrome. This breaks some UI's that rely on lots of text flowing in a particular way; in rare instances, GMail, for example.

In the Google home page example, one level up from the <a> element is a <font> tag with size="-1". There is where the inherited value of 13px should come from.

Changing the desktop DPI to force 96 DPI can help get the value closer to the correct value in Epiphany/Webkit but it is still not quite correct.
Comment 1 Xan Lopez 2009-10-23 05:21:29 PDT
Basically the problem is that epiphany uses the "minimum-logical-font-size" setting (which you set in Preferences), and it seems to break layout in some cases. Before we were using "minimum-font-size", which was even worse. Not sure if this is a bug in WebKit or if we are somehow using it wrong.
Comment 2 Martin Robinson 2010-12-29 23:35:16 PST
I think the real issue here is that Epiphany overrides WebKitGTK+'s default font size (12 points - 16px) with the GNOME setting. This leads users to bump the minimum font size (which normally people leave alone). All this leads to broken layouts, no matter if the setting corresponds to minimum-font-size or minimum-logical-font-size. A minimum-font-size setting of 0-2px should be fine for most pages as long as the default font size is correct.

Anyhow, closing as this is really an Epiphany bug.