Bug 26399 - REGRESSION: java applet accessibility broken
Summary: REGRESSION: java applet accessibility broken
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-14 23:04 PDT by chris fleizach
Modified: 2009-06-14 23:12 PDT (History)
0 users

See Also:


Attachments
patch (7.61 KB, patch)
2009-06-14 23:06 PDT, chris fleizach
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description chris fleizach 2009-06-14 23:04:13 PDT
the accessibility of java applets is broken is safari 4.0. 

it looks like the attachment view holding the java applet is not actually the object in the AX hierarchy
Comment 1 chris fleizach 2009-06-14 23:06:53 PDT
Created attachment 31281 [details]
patch
Comment 2 chris fleizach 2009-06-14 23:12:02 PDT
http://trac.webkit.org/changeset/44678