Bug 26049 - Worker exception handling does not match the spec
Summary: Worker exception handling does not match the spec
Status: RESOLVED DUPLICATE of bug 25150
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-27 15:00 PDT by Andrew Wilson
Modified: 2009-05-28 04:11 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Wilson 2009-05-27 15:00:28 PDT
Currently, worker exception handling doesn't match the spec (distilling section 4.7 of the Web Workers spec and section 5.5.6.5 of the HTML5 spec):

1) We need to expose errors via WorkerContext.onerror
2) If WorkerContext.onerror() does not return false (HTML5 5.5.6.5), then we need to forward the error to the Worker object.
3) If the event is not cancelled by the error handler, then it is reported to the user via the error console (or forwarded up to the parent Worker object, in the case of nested workers).
Comment 1 Andrew Wilson 2009-05-27 15:33:11 PDT
One other thing to note - the spec currently claims that error events in workers are dispatched via the queue. This language in the spec is going away - they will be dispatched synchronously, just like error events in pages.
Comment 2 Alexey Proskuryakov 2009-05-28 04:11:46 PDT

*** This bug has been marked as a duplicate of 25150 ***