Bug 25283 - [Qt] Loading a historyItem with a frame does not do the correct thing
Summary: [Qt] Loading a historyItem with a frame does not do the correct thing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: History (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2009-04-17 18:29 PDT by Benjamin Meyer
Modified: 2011-03-27 09:02 PDT (History)
9 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Meyer 2009-04-17 18:29:33 PDT
When browsing around in a site that has frames and you follow a link with target=_top and then hit the back button only the url of the top frame is loaded the child frames are not restored.

Test page:  http://meyerhome.net/~ben/frametest/

This is also a bug in gtk.
Comment 1 Alexey Proskuryakov 2010-01-14 11:21:08 PST
This test page is no longer available.
Comment 2 Benjamin Meyer 2010-01-14 12:05:14 PST
I'll move it to a better spot shortly.  That url is home test box which as you pointed out can change :)
Comment 3 Antonio Gomes 2010-01-19 10:54:01 PST
(In reply to comment #2)
> I'll move it to a better spot shortly.  That url is home test box which as you
> pointed out can change :)

benjamin, did you move the TC to somewhere else available ?
Comment 4 Benjamin Meyer 2010-01-19 11:59:36 PST
I have moved it to a more available location http://icefox.net/frametest/
Comment 5 Jesus Sanchez-Palencia 2010-05-13 13:56:37 PDT
Reproduced on Snow Leopard with Qt 4.7 trunk (HEAD 03f8f1df0d88f5ffe0b3120cffce614cbeefdb70) and WebKit trunk (r59155).
Comment 6 Robert Hogan 2010-11-25 11:48:49 PST
(In reply to comment #5)
> Reproduced on Snow Leopard with Qt 4.7 trunk (HEAD 03f8f1df0d88f5ffe0b3120cffce614cbeefdb70) and WebKit trunk (r59155).

The test is gone again. Do you still have a copy Benjamin?
Comment 7 Benjamin Meyer 2010-11-25 15:26:02 PST
New (much more perm link) http://icefox.github.com/webkit_bugs/frame_history/
Comment 8 Robert Hogan 2010-11-25 15:32:07 PST
(In reply to comment #7)
> New (much more perm link) http://icefox.github.com/webkit_bugs/frame_history/

This works fine in QtTestBrowser - unless I'm misunderstanding the test. I get the same behaviour in Chromium too.
Comment 9 Benjamin Meyer 2010-11-25 21:40:03 PST
Sounds like someone has fixed the qtwebkit port.  If you can confirm that it is broken for you in 4.6 then you can mark this as fixed.
Comment 10 Luiz Agostini 2011-03-02 15:22:39 PST
seems to be working. I had the same behavior from QtTestBrowser and Chrome in Linux and Snow Leopard. The same for Safari in Snow Leopard.
Comment 11 Andreas Kling 2011-03-27 09:02:24 PDT
Fix confirmed :3