Bug 24863 - Reflection drawing is broken with accelerated-compositing layers
Summary: Reflection drawing is broken with accelerated-compositing layers
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 26652 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-26 17:38 PDT by Simon Fraser (smfr)
Modified: 2009-06-23 14:25 PDT (History)
1 user (show)

See Also:


Attachments
WIP patch (5.64 KB, patch)
2009-06-22 23:07 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Final patch (9.39 KB, patch)
2009-06-23 14:20 PDT, Simon Fraser (smfr)
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2009-03-26 17:38:06 PDT
If an element has style that makes it composited, but also has reflection, then the reflection fails to render.
Comment 1 Simon Fraser (smfr) 2009-03-26 17:38:28 PDT
<rdar://problem/6729013>
Comment 2 Simon Fraser (smfr) 2009-06-22 23:07:56 PDT
Created attachment 31706 [details]
WIP patch
Comment 3 Simon Fraser (smfr) 2009-06-23 13:31:32 PDT
*** Bug 26652 has been marked as a duplicate of this bug. ***
Comment 4 Simon Fraser (smfr) 2009-06-23 14:20:41 PDT
Created attachment 31736 [details]
Final patch
Comment 5 Dave Hyatt 2009-06-23 14:23:47 PDT
Comment on attachment 31736 [details]
Final patch

r=me
Comment 6 Simon Fraser (smfr) 2009-06-23 14:25:44 PDT
http://trac.webkit.org/changeset/45005