Bug 24560 - Flash swf crashes Safari 4 + nightly webkit indefinitely
Summary: Flash swf crashes Safari 4 + nightly webkit indefinitely
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://bit.ly/13kNXD
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-12 14:21 PDT by Faruk Ates
Modified: 2009-03-12 18:49 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Faruk Ates 2009-03-12 14:21:27 PDT
The flash swf on http://bit.ly/13kNXD indefinitely crashes Safari 4 / latest WebKit nightly.

It also crashes Firefox 3, but it does NOT crash the latest Opera release, so there might be a way to prevent it from crashing Safari.
Comment 1 Mark Rowe (bdash) 2009-03-12 17:48:20 PDT
The crash is inside the Flash plug-in.  Please feel free to report the crash to Adobe.
Comment 2 Faruk Ates 2009-03-12 17:59:49 PDT
Yes I know it's inside the Flash player, my point is, Opera manages to keep itself alive despite of that. Why shouldn't Safari be able to do the same? If we can make Safari/Webkit more robust against the likes of Flash and its crashing nature, wouldn't that be a really useful thing? Flash is the cause of 90%+ of all my Webkit crashes so I dare say that adding some extra "fortification" against Flash's problems would be a worthwhile payoff.

(I'll leave this resolved invalid for now, unless I don't get a response to my question by next week or so, after which I'll reopen in the hopes of getting an answer :-))
Comment 3 Mark Rowe (bdash) 2009-03-12 18:49:43 PDT
Flash has browser-specific code, so it's not clear that Opera is doing anything special to avoid crashing here.  It could easily be that Flash is taking a different code path when in Opera and avoiding the buggy code path.

Preventing plug-ins from crashing the host application is covered by bug 17651.