Bug 245159 - Align "UA" stylesheet for "fieldset" with HTML Spec
Summary: Align "UA" stylesheet for "fieldset" with HTML Spec
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: Safari Technology Preview
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 188553 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-09-13 15:21 PDT by Ahmad Saleem
Modified: 2023-04-07 16:35 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ahmad Saleem 2022-09-13 15:21:19 PDT
Originating from bug 245156

I tried to do all changes in one go and got quite a lot of failures and difficult to manage them, so I am going to separate them one by one and land them.

It would be easier to manage for me and this is about this one below:

3) fieldset element needs to change to "min-inline-size: min-content;" from "min-width: min-content;"

https://html.spec.whatwg.org/#the-fieldset-and-legend-elements

In case, if I am not able to do it and had to close my PR, I will share details on genuine test failures or why this is no go at the moment for Webkit so someone else can take a look in future.

Thanks!
Comment 1 EWS 2022-09-14 11:17:56 PDT
Committed 254485@main (3e77428f1d57): <https://commits.webkit.org/254485@main>

Reviewed commits have been landed. Closing PR #4332 and removing active labels.
Comment 2 Radar WebKit Bug Importer 2022-09-14 11:18:20 PDT
<rdar://problem/99927651>
Comment 3 Ahmad Saleem 2023-04-07 16:35:46 PDT
*** Bug 188553 has been marked as a duplicate of this bug. ***