Bug 242800 - [ iOS15 ] fast/css/counters/element-removal-crash.xhtml is a flaky failure
Summary: [ iOS15 ] fast/css/counters/element-removal-crash.xhtml is a flaky failure
Status: RESOLVED DUPLICATE of bug 239405
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-07-15 08:48 PDT by Hercules Hjalmarsson
Modified: 2022-07-15 18:01 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hercules Hjalmarsson 2022-07-15 08:48:02 PDT
fast/css/counters/element-removal-crash.xhtml

Is a flaky text failure on iOS15 ToT.

HISTORY:
https://results.webkit.org/?suite=layout-tests&test=fast%2Fcss%2Fcounters%2Felement-removal-crash.xhtml

DIFF:
--- /Volumes/Data/worker/Apple-iOS-15-Simulator-Release-arm64-WK2-Tests/build/layout-test-results/fast/css/counters/element-removal-crash-expected.txt
+++ /Volumes/Data/worker/Apple-iOS-15-Simulator-Release-arm64-WK2-Tests/build/layout-test-results/fast/css/counters/element-removal-crash-actual.txt
@@ -1 +1,6 @@
+This page contains the following errors:
+
+error on line 32 at column 1: Extra content at the end of the document
+Below is a rendering of the page up to the first error.
+
 PASS

DIFF URL:
https://build.webkit.org/results/Apple-iOS-15-Simulator-Release-arm64-WK2-Tests/252496%40main%20(229)/fast/css/counters/element-removal-crash-pretty-diff.html
Comment 1 Radar WebKit Bug Importer 2022-07-15 08:48:34 PDT
<rdar://problem/97076721>
Comment 2 Hercules Hjalmarsson 2022-07-15 08:58:05 PDT
I was able to reproduce the issue on iOS15 ToT by running 1000 iterations of command:

run-webkit-tests -f --force fast/css/counters/element-removal-crash.xhtml
Comment 3 Hercules Hjalmarsson 2022-07-15 09:12:25 PDT
This text issue appears to have first flakily failed at 249544@main on iOS15. However, 249544@main doesn't seem to have caused it since this issue has been ongoing on macOS since before 249544@main.
Comment 4 EWS 2022-07-15 09:28:31 PDT
Test gardening commit 252507@main (633d94834784): <https://commits.webkit.org/252507@main>

Reviewed commits have been landed. Closing PR #2453 and removing active labels.
Comment 5 Alexey Proskuryakov 2022-07-15 17:20:53 PDT
We have three existing bugs for this test, need to clean this up.
Comment 6 Hercules Hjalmarsson 2022-07-15 18:01:27 PDT

*** This bug has been marked as a duplicate of bug 239405 ***