Bug 24164 - Bad Request error at GMail, started after OS 10.5.6 update
Summary: Bad Request error at GMail, started after OS 10.5.6 update
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Website (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://mail.google.com/
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-25 11:01 PST by Randall Farmer
Modified: 2009-02-25 14:00 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Randall Farmer 2009-02-25 11:01:04 PST
Sometimes I get a Bad Request 400 error at the GMail login screen (or, if I'm already logged in, the GMail UI can't do anything requiring server interaction).  Clearing cookies solves it temporarily.

Surely this is a duplicate, but scanning a few search result lists didn't turn anything up.  Switched to Firefox once because of this, trying the Safari 4 beta but the problem is still there and will probably give in again.  Here are lots of reports:

http://mail.google.com/support/bin/static.py?page=known_issues.cs&issue=140493&bucket=14974
http://mvgfr-geek.blogspot.com/2008/12/gmail-bad-request-error-400.html
http://staynalive.com/tags/gmail/
http://blogoscoped.com/forum/133251.html
http://www.google.com/search?q=gmail+400
Comment 1 Mark Rowe (bdash) 2009-02-25 12:57:40 PST
Cookies are handled by the system CFNetwork framework, not by WebKit.  You should file bug reports against CFNetwork at <http://bugreport.apple.com/>.
Comment 2 Randall Farmer 2009-02-25 14:00:55 PST
Thanks, reported via ADC.