Bug 24052 - hotmail.com message delete function does not work
Summary: hotmail.com message delete function does not work
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.hotmail.com
Keywords: InRadar
: 24075 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-19 18:31 PST by jtressle
Modified: 2009-03-02 09:21 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jtressle 2009-02-19 18:31:57 PST
Hotmail was upgraded a couple of days ago.  Since then, I cannot get the delete button on hotmail to work.  I can select messages but cannot delete them. 

This function works on Firefox.
Comment 1 Mark Rowe (bdash) 2009-02-22 01:06:25 PST
<rdar://problem/6611174>
Comment 2 Josep Quereda 2009-02-24 16:58:38 PST
Is it a bug on Webkit or a "bug" on the upgraded hotmail?

Now the public beta of Safari 4 also cannot access to the hotmail messages.

Tried the latest webkit release r41176, with the same results. Don't work.

Just for test, I have tried using the Develop menu of Safari, changing the User Agent to "Firefox 3.0.5 - Mac" and woo hoo!!! I can access to the messages as ever. It works fine!
Also, I have tried to change user agent to "Opera 9.63 - Mac" and it works really well too.

Using "Internet Explorer 7" and 6 as user agent is not working.

If Webkit/Safari can access well to hotmail messages using the Firefox 3.0.5 user agent... is this a bug of Webkit or is a "bug" on the filters of the scripts on the new hotmail?
Comment 3 Geoffrey Garen 2009-02-25 17:38:51 PST
Committed revision 41232.
Comment 4 Feng Qian 2009-02-25 21:05:33 PST
When I was looking at issue 24075 this afternoon, I saw an exception was thrown, something like "setting a property that has only a getter", which is reduced to a test case in issue 24075.

The interesting part is that, fixing issue 24075 also makes hotmail.com working before commitment of revision 41232. Any insights?

(In reply to comment #3)
> Committed revision 41232.
> 

Comment 5 Feng Qian 2009-03-02 09:21:06 PST
*** Bug 24075 has been marked as a duplicate of this bug. ***