Bug 236987 - Authenticated encryption console logging causing performance regressions
Summary: Authenticated encryption console logging causing performance regressions
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kate Cheney
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-02-21 11:37 PST by Kate Cheney
Modified: 2022-02-22 11:00 PST (History)
6 users (show)

See Also:


Attachments
Patch (36.13 KB, patch)
2022-02-21 11:39 PST, Kate Cheney
no flags Details | Formatted Diff | Diff
Patch (41.37 KB, patch)
2022-02-21 13:06 PST, Kate Cheney
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kate Cheney 2022-02-21 11:37:15 PST
Authenticated encryption console logging causing performance regressions
Comment 1 Kate Cheney 2022-02-21 11:39:57 PST
Created attachment 452751 [details]
Patch
Comment 2 Kate Cheney 2022-02-21 11:40:33 PST
rdar://89108253
Comment 3 Chris Dumez 2022-02-21 11:54:05 PST
Comment on attachment 452751 [details]
Patch

r=me
Comment 4 Kate Cheney 2022-02-21 12:43:32 PST
Looks like I missed updating expectations for a few GTK tests, will fix those.
Comment 5 Kate Cheney 2022-02-21 13:06:45 PST
Created attachment 452760 [details]
Patch
Comment 6 Kate Cheney 2022-02-22 07:24:32 PST
Comment on attachment 452760 [details]
Patch

Build and test failures are unrelated.
Comment 7 Jonathan Bedard 2022-02-22 07:27:31 PST
3 failures in https://ews-build.webkit.org/#/builders/70/builds/967 are known and resolved by a revert this morning.
Comment 8 Kate Cheney 2022-02-22 09:37:07 PST
Comment on attachment 452760 [details]
Patch

iOS test failure seems quite unrelated, trying cq again
Comment 9 EWS 2022-02-22 11:00:20 PST
Committed r290319 (247641@main): <https://commits.webkit.org/247641@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 452760 [details].