Bug 236126 - [ Mac wk1 Release ] imported/w3c/web-platform-tests/html/user-activation/activation-trigger-pointerevent.html is a constant text failure
Summary: [ Mac wk1 Release ] imported/w3c/web-platform-tests/html/user-activation/acti...
Status: RESOLVED DUPLICATE of bug 236128
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2022-02-03 22:11 PST by Robert Jenner
Modified: 2022-05-18 15:12 PDT (History)
3 users (show)

See Also:


Attachments
Test list used for reproduction (51.06 KB, text/plain)
2022-03-08 15:20 PST, Robert Jenner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Jenner 2022-02-03 22:11:46 PST
imported/w3c/web-platform-tests/html/user-activation/activation-trigger-pointerevent.html 

is a constant text failure on Mac wk1 Release. It is also flaky failing on Mac wk1 debug. 

HISTORY:
https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2Fhtml%2Fuser-activation%2Factivation-trigger-pointerevent.html

DIFF:
https://build.webkit.org/results/Apple-Monterey-Release-AppleSilicon-WK1-Tests/r289102%20(1549)/imported/w3c/web-platform-tests/html/user-activation/activation-trigger-pointerevent-pretty-diff.html

 
 Click anywhere in the document.
 
-FAIL Activation through  pointerevent click assert_true:  pointerup event should result in activation expected true got false
+Harness Error (TIMEOUT), message = null
 
+TIMEOUT Activation through  pointerevent click Test timed out
+
Comment 1 Radar WebKit Bug Importer 2022-02-03 22:15:16 PST
<rdar://problem/88474277>
Comment 2 Robert Jenner 2022-02-03 22:15:25 PST
This test appears to have been failing on Mac wk1 release since it was it was introduced at r287846:

https://trac.webkit.org/changeset/287846/webkit
Comment 3 Robert Jenner 2022-02-23 18:25:25 PST
I have marked expectations as [ Pass Failure ] for Mac wk1 here:

https://trac.webkit.org/changeset/290409/webkit
Comment 4 Robert Jenner 2022-03-08 15:19:48 PST
This failure does not reproduce standalone. I even ran it up-to 10000 iterations, and I did not get a failure. 

I was however, finally able to reproduce it in a test-list. So this appears to be a test-list order issue. I am attaching the list I used for reproduction to this bug. This is how I ran the test in order to get it to reproduce, and I did reproduce the failure at Monterey Release ToT wk1. Note, that I downloaded the built product for a release build to test this. 

run-webkit-tests --nobuild --no-show-results --test-list <path to test list location> --release --force -1 --child-process=1 

Running the test like that, I was able to reproduce the failure every time.
Comment 5 Robert Jenner 2022-03-08 15:20:25 PST
Created attachment 454157 [details]
Test list used for reproduction
Comment 6 Robert Jenner 2022-03-08 15:26:09 PST
I was able to narrow down, and determine that when the following test:

"imported/w3c/web-platform-tests/html/user-activation/activation-trigger-mouse-right.html"

is run before "imported/w3c/web-platform-tests/html/user-activation/activation-trigger-pointerevent.html" it causes it to fail. 


When I ran the test-list WITHOUT "imported/w3c/web-platform-tests/html/user-activation/activation-trigger-mouse-right.html" the test passes.
Comment 7 Ryan Haddad 2022-05-18 15:12:30 PDT
Looks like this has been passing since the test causing the failure was skipped in https://bugs.webkit.org/show_bug.cgi?id=236128.

*** This bug has been marked as a duplicate of bug 236128 ***