Bug 233989 - [GPU Process] [Filters] Enable Filter rendering in GPU Process
Summary: [GPU Process] [Filters] Enable Filter rendering in GPU Process
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Said Abou-Hallawa
URL:
Keywords: InRadar
: 234027 (view as bug list)
Depends on: 233973 234024 234086 234099
Blocks: 231253
  Show dependency treegraph
 
Reported: 2021-12-08 00:00 PST by Said Abou-Hallawa
Modified: 2021-12-10 00:13 PST (History)
22 users (show)

See Also:


Attachments
Patch (4.92 KB, patch)
2021-12-08 00:02 PST, Said Abou-Hallawa
no flags Details | Formatted Diff | Diff
Patch (10.63 KB, patch)
2021-12-09 13:16 PST, Said Abou-Hallawa
heycam: review+
Details | Formatted Diff | Diff
Patch (13.48 KB, patch)
2021-12-09 20:14 PST, Said Abou-Hallawa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Said Abou-Hallawa 2021-12-08 00:00:43 PST
This will move applying the CSSFilters and the CSSFilterImageValue to GPUProcess. For now if the CSSFilter includes a referenced SVGFilter the whole CSSFilter will be applied in WebProcess.
Comment 1 Said Abou-Hallawa 2021-12-08 00:02:03 PST
Created attachment 446317 [details]
Patch
Comment 2 Said Abou-Hallawa 2021-12-08 12:46:34 PST
I will make this bug enables CSSFilter and SVGFilter in GPUProcess.
Comment 3 Said Abou-Hallawa 2021-12-08 12:48:19 PST
*** Bug 234027 has been marked as a duplicate of this bug. ***
Comment 4 Said Abou-Hallawa 2021-12-09 13:16:39 PST
Created attachment 446597 [details]
Patch
Comment 5 Cameron McCormack (:heycam) 2021-12-09 13:26:09 PST
Does bug 234099 (blocking this one) need to be done before this one?
Comment 6 Cameron McCormack (:heycam) 2021-12-09 14:26:10 PST
Comment on attachment 446597 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=446597&action=review

> Source/WebCore/rendering/svg/RenderSVGResourceFilter.cpp:157
> +    auto hostWindow = renderer.view().frameView().root() ? renderer.view().frameView().root()->hostWindow() : nullptr;

(I see this fragment so often that I wonder if createImageBuffer functions should take the renderer as an argument instead of the host window.)
Comment 7 Darin Adler 2021-12-09 14:54:27 PST
Comment on attachment 446597 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=446597&action=review

>> Source/WebCore/rendering/svg/RenderSVGResourceFilter.cpp:157
>> +    auto hostWindow = renderer.view().frameView().root() ? renderer.view().frameView().root()->hostWindow() : nullptr;
> 
> (I see this fragment so often that I wonder if createImageBuffer functions should take the renderer as an argument instead of the host window.)

Or just a hostWindow helper function so there’s not a separate line of code every time.
Comment 8 Said Abou-Hallawa 2021-12-09 20:14:28 PST
Created attachment 446656 [details]
Patch
Comment 9 EWS 2021-12-10 00:12:37 PST
Committed r286835 (245068@main): <https://commits.webkit.org/245068@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 446656 [details].
Comment 10 Radar WebKit Bug Importer 2021-12-10 00:13:21 PST
<rdar://problem/86310865>