Bug 23378 - table incorrectly draws border after <td colspan=2>
Summary: table incorrectly draws border after <td colspan=2>
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-16 01:47 PST by Bill Keese
Modified: 2012-03-26 11:43 PDT (History)
1 user (show)

See Also:


Attachments
rendering on ff11 (7.21 KB, image/gif)
2012-02-26 09:39 PST, Bill Keese
no flags Details
rendering on safari4 or safari5 mac (7.23 KB, image/gif)
2012-02-26 09:40 PST, Bill Keese
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Keese 2009-01-16 01:47:07 PST
Webkit and safari are drawing a border between the second and third <td> in this example:

<table style="border:1px solid #7EABCD;border-collapse:collapse;">
            <tbody>
                     <tr>
                              <td></td>
                              <td colspan="2">one</td>
                              <td>&nbsp;&nbsp;</td>
                    </tr>
           </tbody>
</table>

Can also be seen in the drop down menus from the menu bar in http://archive.dojotoolkit.org/dojo-2009-01-16/dojotoolkit/dijit/tests/test_Menu.html

In order to reproduce this bug, it has to meet the following: 
1. border-collapse is set to collapse 
2. a td with colspan=2
3. there is a td before the colspan=2 td
Comment 1 liucougar 2009-01-16 22:15:07 PST
a workaround is to explicitly set border-right to hidden for such a td (as mentioned in http://bugs.dojotoolkit.org/ticket/8427#comment:5 )

see http://bugs.dojotoolkit.org/changeset/16369 for the workaround employed in dojo

(after this fix, the test_Menu.html page mentioned in the report does not show this bug any more, but the bug is still there, and still need a fix in webkit)
Comment 2 liucougar 2009-01-18 02:13:46 PST
the real workaround is committed to dojo in http://bugs.dojotoolkit.org/changeset/16396

(quote around 2 is required)
Comment 3 Julien Chaffraix 2012-02-23 17:25:43 PST
I checked the test case today but I don't see any difference between our rendering and FF / Opera. I am not sure I completely understand the issue and without a reproduction, it will be difficult to look into really fixing it.

Bill, I know this is an very old dojo bug but if you could clarify the test case I could find some time to investigate the issue in WebKit. Thanks!
Comment 4 Bill Keese 2012-02-26 09:39:31 PST
Created attachment 128919 [details]
rendering on ff11
Comment 5 Bill Keese 2012-02-26 09:40:01 PST
Created attachment 128920 [details]
rendering on safari4 or safari5 mac
Comment 6 Bill Keese 2012-02-26 09:44:56 PST
Hi Julien,

Thanks for the response.   Although the problem still occurs on Safari5/mac, it's not happening on the latest Chrome or the webkit nightly.   Looks like it's fixed!
Comment 7 Julien Chaffraix 2012-03-26 11:43:40 PDT
Hi Bill,

> Although the problem still occurs on Safari5/mac, it's not happening on the latest Chrome or the webkit nightly. Looks like it's fixed!

Good to hear. I am going to close this bug FIXED as WebKit nightly doesn't show the issue. Feel free to comment in this bug if something still happens or open a new bug (CC'ing me in this case so it's on someone's radar). Thanks!