Bug 233345 - [ Monterey ] TestWebKitAPI.PrivateClickMeasurement.EphemeralWithAttributedBundleIdentifier (API-test) is a constant timeout
Summary: [ Monterey ] TestWebKitAPI.PrivateClickMeasurement.EphemeralWithAttributedBun...
Status: RESOLVED DUPLICATE of bug 226548
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit API (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-11-18 17:00 PST by Robert Jenner
Modified: 2021-12-22 10:00 PST (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Jenner 2021-11-18 17:00:17 PST
TestWebKitAPI.PrivateClickMeasurement.EphemeralWithAttributedBundleIdentifier

is a constantly timing out API-test on Monterey. 

HISTORY:
https://results.webkit.org/?suite=api-tests&test=TestWebKitAPI.PrivateClickMeasurement.EphemeralWithAttributedBundleIdentifier
Comment 1 Radar WebKit Bug Importer 2021-11-18 17:00:48 PST
<rdar://problem/85574990>
Comment 2 Robert Jenner 2021-11-19 11:27:53 PST
I was able to reproduce this timeout on a Release ToT build. Using the following test:

Run-api-tests --release TestWebKitAPI.PrivateClickMeasurement.EphemeralWithAttributedBundleIdentifier

I do want to note that I was not able to reproduce this with a Debug or a Production build. I had to specifically download a Release build, and that's where I was easily able to reproduce the timeout.
Comment 3 Robert Jenner 2021-11-19 12:14:08 PST
Disabled test here:
https://trac.webkit.org/changeset/286072/webkit
Comment 4 Alex Christensen 2021-12-22 09:59:25 PST

*** This bug has been marked as a duplicate of bug 226548 ***
Comment 5 Alex Christensen 2021-12-22 10:00:26 PST
https://trac.webkit.org/changeset/287359/webkit fixed this