Bug 231816 - [ iOS Catalina ] imported/w3c/web-platform-tests/css/css-transforms/crashtests/transform-marquee-resize-div-image-001.html is a flaky failure
Summary: [ iOS Catalina ] imported/w3c/web-platform-tests/css/css-transforms/crashtest...
Status: RESOLVED DUPLICATE of bug 230327
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-10-15 10:31 PDT by ayumi_kojima
Modified: 2021-10-28 15:00 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ayumi_kojima 2021-10-15 10:31:57 PDT
imported/w3c/web-platform-tests/css/css-transforms/crashtests/transform-marquee-resize-div-image-001.html

Is a flaky failure on Catalina Release. The test has also started appearing on iOS-14-Simulator-WK2-Tests-EWS as a flaky failure.

History: https://results.webkit.org/?suite=layout-tests&test=imported/w3c/web-platform-tests/css/css-transforms/crashtests/transform-marquee-resize-div-image-001.html

The flaky failures is not seen on iOS in the open source.

Result page: https://ews-build.s3-us-west-2.amazonaws.com/iOS-14-Simulator-WK2-Tests-EWS/r441094-23381/results.html

It started being flaky on iOS around October 13. Build: https://ews-build.webkit.org/#/builders/51/builds/23362

Diff:

--- /Volumes/Data/worker/iOS-14-Simulator-WK2-Tests-EWS/build/layout-test-results/imported/w3c/web-platform-tests/css/css-transforms/crashtests/transform-marquee-resize-div-image-001-expected.txt
+++ /Volumes/Data/worker/iOS-14-Simulator-WK2-Tests-EWS/build/layout-test-results/imported/w3c/web-platform-tests/css/css-transforms/crashtests/transform-marquee-resize-div-image-001-actual.txt
@@ -4,7 +4,7 @@
   RenderBlock {HTML} at (0,0) size 800x46
 layer at (8,8) size 784x30
   RenderBody {BODY} at (8,8) size 784x30
-layer at (8,8) size 784x25 scrollX -784
+layer at (8,8) size 784x25 scrollX -778
   RenderBlock {MARQUEE} at (0,0) size 784x25
     RenderBlock {DIV} at (0,0) size 20x25
       RenderImage {IMG} at (0,0) size 20x20

The test is marked as pass/failure on Catalina in Bug 230327.
Comment 1 Radar WebKit Bug Importer 2021-10-15 10:33:12 PDT
<rdar://problem/84307637>
Comment 2 ayumi_kojima 2021-10-15 10:36:19 PDT
Marked test expectations https://trac.webkit.org/changeset/284253/webkit
Comment 3 ayumi_kojima 2021-10-28 15:00:00 PDT

*** This bug has been marked as a duplicate of bug 230327 ***