Bug 231282 - ASSERTION FAILED: clipRectsContext.rootLayer == m_clipRectsCache->m_clipRectsRoot[clipRectsType] in WebCore::RenderLayer::updateClipRects
Summary: ASSERTION FAILED: clipRectsContext.rootLayer == m_clipRectsCache->m_clipRects...
Status: RESOLVED DUPLICATE of bug 117928
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-10-05 23:05 PDT by Fujii Hironori
Modified: 2021-10-21 16:41 PDT (History)
5 users (show)

See Also:


Attachments
test case (2.89 KB, text/html)
2021-10-05 23:05 PDT, Fujii Hironori
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fujii Hironori 2021-10-05 23:05:57 PDT
Created attachment 440332 [details]
test case

ASSERTION FAILED: clipRectsContext.rootLayer == m_clipRectsCache->m_clipRectsRoot[clipRectsType] in WebCore::RenderLayer::updateClipRects

I'm testing with WinCairo Debug WK2 r283591.

ASSERTION FAILED: clipRectsContext.rootLayer == m_clipRectsCache->m_clipRectsRoot[clipRectsType]
C:\home\webkit\gc\Source\WebCore\rendering/RenderLayer.cpp(4417) : WebCore::RenderLayer::updateClipRects
1   00007FF94281217B WTFCrash
2   00007FF8DE05AAAE WTFCrashWithInfo
3   00007FF8E310E6DB WebCore::RenderLayer::updateClipRects
4   00007FF8E311B82B WebCore::RenderLayer::parentClipRects
5   00007FF8E311B933 WebCore::RenderLayer::backgroundClipRect
6   00007FF8E31086BC WebCore::RenderLayer::calculateRects
7   00007FF8E3108C13 WebCore::RenderLayer::collectFragments
8   00007FF8E3114A2E WebCore::RenderLayer::paintLayerContents
9   00007FF8E3113C21 WebCore::RenderLayer::paintLayerContentsAndReflection
10  00007FF8E31139DC WebCore::RenderLayer::paintLayerWithEffects
11  00007FF8E3113378 WebCore::RenderLayer::paintLayer
12  00007FF8E31153A4 WebCore::RenderLayer::paintList
13  00007FF8E3114D52 WebCore::RenderLayer::paintLayerContents
14  00007FF8E3113C21 WebCore::RenderLayer::paintLayerContentsAndReflection
15  00007FF8E31139DC WebCore::RenderLayer::paintLayerWithEffects
16  00007FF8E3113378 WebCore::RenderLayer::paintLayer
17  00007FF8E31153A4 WebCore::RenderLayer::paintList
18  00007FF8E3114D52 WebCore::RenderLayer::paintLayerContents
19  00007FF8E3113C21 WebCore::RenderLayer::paintLayerContentsAndReflection
20  00007FF8E31139DC WebCore::RenderLayer::paintLayerWithEffects
21  00007FF8E3113378 WebCore::RenderLayer::paintLayer
22  00007FF8E3107F4A WebCore::RenderLayer::paint
23  00007FF8E29ADC05 WebCore::FrameView::paintContents
24  00007FF8E2B8C204 WebCore::ScrollView::paint
25  00007FF8DE1235D7 WebKit::LayerTreeHost::paintContents
26  00007FF8E2CBA0E4 WebCore::GraphicsLayer::paintGraphicsLayerContents
27  00007FF8DFC18F40 WebCore::BitmapTexture::updateContents
28  00007FF8DFC29905 WebCore::TextureMapperTile::updateContents
29  00007FF8DFC4AF64 WebCore::TextureMapperTiledBackingStore::updateContents
30  00007FF8DFC46D51 WebCore::GraphicsLayerTextureMapper::updateBackingStoreIfNeeded
31  00007FF8DFC45BEE WebCore::GraphicsLayerTextureMapper::updateBackingStoreIncludingSubLayers
Exception thrown at 0x00007FF942812180 (WTF.dll) in WebKitWebProcess.exe: 0xC0000005: Access violation writing location 0x00000000BBADBEEF.
Comment 1 Simon Fraser (smfr) 2021-10-06 10:52:32 PDT
There are several bugs on this assertion already.
Comment 2 Radar WebKit Bug Importer 2021-10-12 23:06:20 PDT
<rdar://problem/84182716>
Comment 3 Smoley 2021-10-21 16:41:03 PDT

*** This bug has been marked as a duplicate of bug 117928 ***