Bug 230974 - [macOS] Allow audio service in the WebContent process on older versions
Summary: [macOS] Allow audio service in the WebContent process on older versions
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Per Arne Vollan
URL:
Keywords: InRadar
: 231449 231872 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-09-29 11:54 PDT by Per Arne Vollan
Modified: 2022-02-09 09:38 PST (History)
6 users (show)

See Also:


Attachments
Patch (1.38 KB, patch)
2021-09-29 11:56 PDT, Per Arne Vollan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Per Arne Vollan 2021-09-29 11:54:10 PDT
Older versions of macOS still need access to "com.apple.audio.AudioComponentRegistrar" in the WebContent process.
Comment 1 Per Arne Vollan 2021-09-29 11:54:33 PDT
<rdar://82445437>
Comment 2 Per Arne Vollan 2021-09-29 11:56:57 PDT
Created attachment 439637 [details]
Patch
Comment 3 Brent Fulgham 2021-09-29 11:57:26 PDT
Comment on attachment 439637 [details]
Patch

r=me
Comment 4 Per Arne Vollan 2021-09-29 16:47:05 PDT
(In reply to Brent Fulgham from comment #3)
> Comment on attachment 439637 [details]
> Patch
> 
> r=me

Thanks for reviewing!
Comment 5 EWS 2021-09-29 17:55:34 PDT
Committed r283289 (242316@main): <https://commits.webkit.org/242316@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 439637 [details].
Comment 6 Jean-Yves Avenard [:jya] 2021-10-12 14:29:05 PDT
*** Bug 231449 has been marked as a duplicate of this bug. ***
Comment 7 Chris Dumez 2021-10-16 18:06:24 PDT
*** Bug 231872 has been marked as a duplicate of this bug. ***
Comment 8 Mani L 2022-02-09 08:14:59 PST
I am in MacOS Catalina version and Safari ~15 and still decodeAudioData doesn't work?

Is there a timeline on when it is supposed to be available?
Comment 9 aaron 2022-02-09 09:16:39 PST
(In reply to Mani L from comment #8)
> I am in MacOS Catalina version and Safari ~15 and still decodeAudioData
> doesn't work?
> 
> Is there a timeline on when it is supposed to be available?

I'm seeing the desired behavior in Safari 15.4 beta on Catalina
Comment 10 Mani L 2022-02-09 09:38:12 PST
Do we know when the beta will be available to global or stable release? As we can’t ask users to download the beta and use our application