Bug 230891 - [Flatpak SDK] Update libsoup3 and friends
Summary: [Flatpak SDK] Update libsoup3 and friends
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Philippe Normand
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-09-28 05:07 PDT by Philippe Normand
Modified: 2021-09-28 08:37 PDT (History)
3 users (show)

See Also:


Attachments
Patch (3.79 KB, patch)
2021-09-28 05:08 PDT, Philippe Normand
no flags Details | Formatted Diff | Diff
Patch (4.92 KB, patch)
2021-09-28 06:50 PDT, Philippe Normand
mcatanzaro: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Normand 2021-09-28 05:07:02 PDT
friends being glib, wpebackend-fdo and rr.
Comment 1 Philippe Normand 2021-09-28 05:08:47 PDT
Created attachment 439460 [details]
Patch
Comment 2 Philippe Normand 2021-09-28 06:50:52 PDT
Created attachment 439471 [details]
Patch
Comment 3 Michael Catanzaro 2021-09-28 07:26:31 PDT
Comment on attachment 439471 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=439471&action=review

> Tools/buildstream/elements/sdk/glib.bst:5
> -  url: gnome_downloads:glib/2.69/glib-2.69.0.tar.xz
> -  ref: 1cdb3fd8610f3c57b6622e5cd68e0a3210561d80b0eceb971eb51fb8b63dbfae
> +  url: gnome_downloads:glib/2.69/glib-2.69.1.tar.xz
> +  ref: f92f34057a091fc8638d91f10cece842cb8618e9a1090b0ddb19cc15a21bf39c

Why are you using this seemingly-arbitrary unstable snapshot of GLib?

GLib 2.70 is available. Better to use that.
Comment 4 Philippe Normand 2021-09-28 07:36:22 PDT
Comment on attachment 439471 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=439471&action=review

>> Tools/buildstream/elements/sdk/glib.bst:5
>> +  ref: f92f34057a091fc8638d91f10cece842cb8618e9a1090b0ddb19cc15a21bf39c
> 
> Why are you using this seemingly-arbitrary unstable snapshot of GLib?
> 
> GLib 2.70 is available. Better to use that.

I used what was required by libsoup 3.0. But yeah sure, I can try to bump further.
Comment 5 Philippe Normand 2021-09-28 08:36:49 PDT
Committed r283169 (242217@main): <https://commits.webkit.org/242217@main>
Comment 6 Radar WebKit Bug Importer 2021-09-28 08:37:21 PDT
<rdar://problem/83623959>