Bug 230325 - [ iOS iPhone ] fast/forms/ios/no-stale-checked-items-in-select-picker.html is a flaky crash (marked as a crash because of a broken pipe)
Summary: [ iOS iPhone ] fast/forms/ios/no-stale-checked-items-in-select-picker.html is...
Status: RESOLVED DUPLICATE of bug 230513
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: WebKit Nightly Build
Hardware: iPhone / iPad Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-09-15 16:35 PDT by ayumi_kojima
Modified: 2021-09-22 11:14 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ayumi_kojima 2021-09-15 16:35:38 PDT
fast/forms/ios/no-stale-checked-items-in-select-picker.html

Is flaky crashing on iOS iPhone.

History: https://results.webkit.org/?suite=layout-tests&test=fast%2Fforms%2Fios%2Fno-stale-checked-items-in-select-picker.html

According to the history, the test has been flaky since the first revision that can be seen in the history (r281749).

Result page: https://build.webkit.org/results/Apple-iOS-14-Simulator-Debug-WK2-Tests/r281826%20(2532)/results.html

It appears that there is no crash log. I will see if I can reproduce locally.

Crash log:

No crash log found for WebKitTestRunnerApp:33830.
Comment 1 Radar WebKit Bug Importer 2021-09-15 16:36:29 PDT
<rdar://problem/83173508>
Comment 2 Alexey Proskuryakov 2021-09-17 17:00:00 PDT
11:49:50.694 70906 worker/5 fast/forms/ios/large-radio-button-is-round.html passed
11:49:53.824 70906 worker/5 worker/5 fast/forms/ios/no-scrolling-when-moving-focus-between-adjacent-fields.html output stderr lines:
11:49:53.825 70906 worker/5   2021-09-17 11:49:51.560 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.825 70906 worker/5   2021-09-17 11:49:52.356 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.825 70906 worker/5   2021-09-17 11:49:52.477 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.826 70906 worker/5   2021-09-17 11:49:52.579 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.826 70906 worker/5   2021-09-17 11:49:52.674 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.826 70906 worker/5   2021-09-17 11:49:52.768 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.826 70906 worker/5   2021-09-17 11:49:52.866 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.827 70906 worker/5   2021-09-17 11:49:52.970 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.827 70906 worker/5   2021-09-17 11:49:53.069 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.827 70906 worker/5   2021-09-17 11:49:53.172 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.828 70906 worker/5   2021-09-17 11:49:53.248 WebKitTestRunnerApp[74381:378805498] Can't find keyplane that supports type 5 for keyboard iPhone-Portrait-PhonePad; using 25960_Portrait_iPhone-Complex-Pad_Default
11:49:53.828 70906 worker/5 fast/forms/ios/no-scrolling-when-moving-focus-between-adjacent-fields.html passed
11:49:54.000 70906 worker/5 killed pid 74381
11:49:54.000 70906 worker/5 This test marked as a crash because of a broken pipe when writing to stdin of the server process.
11:50:34.043 70906 worker/5 worker/5 fast/forms/ios/no-stale-checked-items-in-select-picker.html crashed, (no stderr)
11:50:34.044 70906 worker/5 killing driver
11:50:34.059 70906 worker/5 fast/forms/ios/no-stale-checked-items-in-select-picker.html failed:
11:50:34.059 70906 worker/5 WebKitTestRunnerApp crashed [pid=74381]
Comment 3 ayumi_kojima 2021-09-22 11:14:33 PDT

*** This bug has been marked as a duplicate of bug 230513 ***