Bug 229880 - [ BigSur EWS ] ASSERTION FAILED: m_uncommittedState.state == State::Provisional
Summary: [ BigSur EWS ] ASSERTION FAILED: m_uncommittedState.state == State::Provisional
Status: RESOLVED DUPLICATE of bug 229769
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Mac (Apple Silicon) Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-09-03 10:29 PDT by ayumi_kojima
Modified: 2021-09-03 12:03 PDT (History)
3 users (show)

See Also:


Attachments
Crash log (109.10 KB, text/plain)
2021-09-03 10:30 PDT, ayumi_kojima
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ayumi_kojima 2021-09-03 10:29:38 PDT
Many tests are failing on macOS-AppleSilicon-Big-Sur-Debug-WK2-Tests-EWS.

imported/w3c/web-platform-tests/html/semantics/document-metadata/the-meta-element/color-scheme/meta-color-scheme-single-value-in-shadow-tree.html
imported/w3c/web-platform-tests/html/semantics/document-metadata/the-meta-element/color-scheme/meta-color-scheme-single-value-in-body.html
imported/w3c/web-platform-tests/html/semantics/document-metadata/the-meta-element/pragma-directives/http-equiv-enumerated-ascii-case-insensitive.html
imported/w3c/web-platform-tests/html/semantics/document-metadata/the-meta-element/color-scheme/meta-color-scheme-insert.html
imported/w3c/web-platform-tests/html/semantics/document-metadata/the-style-element/style_type_svg.svg
imported/w3c/web-platform-tests/html/semantics/document-metadata/the-style-element/style_media.html
imported/w3c/web-platform-tests/html/semantics/document-metadata/the-style-element/style_type_change.html
imported/w3c/web-platform-tests/html/semantics/document-metadata/the-style-element/style_load_async.html
imported/w3c/web-platform-tests/html/semantics/document-metadata/the-style-element/style_non_matching_media.html
imported/w3c/web-platform-tests/html/semantics/document-metadata/the-style-element/style_media_change.html
imported/w3c/web-platform-tests/html/semantics/embedded-content/media-elements/interfaces/TextTrack/activeCues.html
imported/w3c/web-platform-tests/html/semantics/embedded-content/media-elements/location-of-the-media-resource/currentSrc.html

ASSERTION FAILED: m_uncommittedState.state == State::Provisional
/Volumes/Data/worker/macOS-AppleSilicon-Big-Sur-Debug-Build-EWS/build/Source/WebKit/UIProcess/PageLoadState.cpp(325) : void WebKit::PageLoadState::didCommitLoad(const Transaction::Token &, WebKit::WebCertificateInfo &, bool, bool)
1   0x1052960ec WTFCrash
2   0x10deea958 std::__1::optional<JSC::JSValue>::optional<JSC::JSValue, 0>(JSC::JSValue&&)
3   0x10f391988 WebKit::PageLoadState::didCommitLoad(WebKit::PageLoadState::Transaction::Token const&, WebKit::WebCertificateInfo&, bool, bool)
4   0x10f4f7500 WebKit::WebPageProxy::didCommitLoadForFrame(WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData&&, WebCore::ResourceRequest&&, unsigned long long, WTF::String const&, bool, WebCore::FrameLoadType, WebCore::CertificateInfo const&, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData const&)
5   0x10f4f6ba4 WebKit::WebPageProxy::commitProvisionalPage(WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData&&, WebCore::ResourceRequest&&, unsigned long long, WTF::String const&, bool, WebCore::FrameLoadType, WebCore::CertificateInfo const&, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData const&)
6   0x10f39907c WebKit::ProvisionalPageProxy::didCommitLoadForFrame(WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData&&, WebCore::ResourceRequest&&, unsigned long long, WTF::String const&, bool, WebCore::FrameLoadType, WebCore::CertificateInfo const&, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData const&)
7   0x10f3f92a0 void IPC::callMemberFunctionImpl<WebKit::ProvisionalPageProxy, void (WebKit::ProvisionalPageProxy::*)(WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData&&, WebCore::ResourceRequest&&, unsigned long long, WTF::String const&, bool, WebCore::FrameLoadType, WebCore::CertificateInfo const&, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData const&), std::__1::tuple<WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData, WebCore::ResourceRequest, unsigned long long, WTF::String, bool, WebCore::FrameLoadType, WebCore::CertificateInfo, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData>, 0ul, 1ul, 2ul, 3ul, 4ul, 5ul, 6ul, 7ul, 8ul, 9ul, 10ul, 11ul, 12ul>(WebKit::ProvisionalPageProxy*, void (WebKit::ProvisionalPageProxy::*)(WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData&&, WebCore::ResourceRequest&&, unsigned long long, WTF::String const&, bool, WebCore::FrameLoadType, WebCore::CertificateInfo const&, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData const&), std::__1::tuple<WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData, WebCore::ResourceRequest, unsigned long long, WTF::String, bool, WebCore::FrameLoadType, WebCore::CertificateInfo, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData>&&, std::__1::integer_sequence<unsigned long, 0ul, 1ul, 2ul, 3ul, 4ul, 5ul, 6ul, 7ul, 8ul, 9ul, 10ul, 11ul, 12ul>)
8   0x10f3eb690 void IPC::callMemberFunction<WebKit::ProvisionalPageProxy, void (WebKit::ProvisionalPageProxy::*)(WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData&&, WebCore::ResourceRequest&&, unsigned long long, WTF::String const&, bool, WebCore::FrameLoadType, WebCore::CertificateInfo const&, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData const&), std::__1::tuple<WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData, WebCore::ResourceRequest, unsigned long long, WTF::String, bool, WebCore::FrameLoadType, WebCore::CertificateInfo, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData>, std::__1::integer_sequence<unsigned long, 0ul, 1ul, 2ul, 3ul, 4ul, 5ul, 6ul, 7ul, 8ul, 9ul, 10ul, 11ul, 12ul> >(std::__1::tuple<WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData, WebCore::ResourceRequest, unsigned long long, WTF::String, bool, WebCore::FrameLoadType, WebCore::CertificateInfo, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData>&&, WebKit::ProvisionalPageProxy*, void (WebKit::ProvisionalPageProxy::*)(WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData&&, WebCore::ResourceRequest&&, unsigned long long, WTF::String const&, bool, WebCore::FrameLoadType, WebCore::CertificateInfo const&, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData const&))
9   0x10f39b49c void IPC::handleMessage<Messages::WebPageProxy::DidCommitLoadForFrame, WebKit::ProvisionalPageProxy, void (WebKit::ProvisionalPageProxy::*)(WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData&&, WebCore::ResourceRequest&&, unsigned long long, WTF::String const&, bool, WebCore::FrameLoadType, WebCore::CertificateInfo const&, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData const&)>(IPC::Decoder&, WebKit::ProvisionalPageProxy*, void (WebKit::ProvisionalPageProxy::*)(WTF::ObjectIdentifier<WebCore::FrameIdentifierType>, WebKit::FrameInfoData&&, WebCore::ResourceRequest&&, unsigned long long, WTF::String const&, bool, WebCore::FrameLoadType, WebCore::CertificateInfo const&, bool, bool, std::__1::optional<WebCore::HasInsecureContent>, WebCore::MouseEventPolicy, WebKit::UserData const&))
10  0x10f39a848 WebKit::ProvisionalPageProxy::didReceiveMessage(IPC::Connection&, IPC::Decoder&)
11  0x10e27b590 IPC::MessageReceiverMap::dispatchMessage(IPC::Connection&, IPC::Decoder&)
12  0x10f3362f0 WebKit::AuxiliaryProcessProxy::dispatchMessage(IPC::Connection&, IPC::Decoder&)
13  0x10f62d03c WebKit::WebProcessProxy::didReceiveMessage(IPC::Connection&, IPC::Decoder&)
14  0x10dd23020 IPC::Connection::dispatchMessage(IPC::Decoder&)
15  0x10dd23768 IPC::Connection::dispatchMessage(std::__1::unique_ptr<IPC::Decoder, std::__1::default_delete<IPC::Decoder> >)
16  0x10dd21d68 IPC::Connection::dispatchIncomingMessages()
17  0x10dd464ac IPC::Connection::enqueueIncomingMessage(std::__1::unique_ptr<IPC::Decoder, std::__1::default_delete<IPC::Decoder> >)::$_12::operator()()
18  0x10dd463b4 WTF::Detail::CallableWrapper<IPC::Connection::enqueueIncomingMessage(std::__1::unique_ptr<IPC::Decoder, std::__1::default_delete<IPC::Decoder> >)::$_12, void>::call()
19  0x1052bf94c WTF::Function<void ()>::operator()() const
20  0x105346108 WTF::RunLoop::performWork()
21  0x10534aed4 WTF::RunLoop::performWork(void*)
22  0x18c0caad4 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__
23  0x18c0caa20 __CFRunLoopDoSource0
24  0x18c0ca70c __CFRunLoopDoSources0
25  0x18c0c9094 __CFRunLoopRun
26  0x18c0c85e8 CFRunLoopRunSpecific
27  0x18ce71688 -[NSRunLoop(NSRunLoop) runMode:beforeDate:]
28  0x104aa74ac WTR::TestController::platformRunUntil(bool&, WTF::Seconds)
29  0x104a5da68 WTR::TestController::runUntil(bool&, WTF::Seconds)
30  0x104a639b0 WTR::TestController::clearBundleIdentifierInNetworkProcess()
31  0x104a62678 WTR::TestController::resetStateToConsistentValues(WTR::TestOptions const&, WTR::TestController::ResetStage)
LEAK: 1 WebFrame
LEAK: 3 RenderObject
LEAK: 1 Page
LEAK: 1 Frame
LEAK: 4 WebCoreNode

The flaky crash is showing up in the open source for some tests: https://results.webkit.org/?suite=layout-tests&test=imported/w3c/web-platform-tests/html/semantics/document-metadata/the-style-element/style_media.html
Comment 1 ayumi_kojima 2021-09-03 10:30:51 PDT
Created attachment 437282 [details]
Crash log
Comment 2 Radar WebKit Bug Importer 2021-09-03 10:44:09 PDT
<rdar://problem/82729973>
Comment 3 ayumi_kojima 2021-09-03 10:56:27 PDT
I was not able to reproduce the crash on BigSur AS using: run-webkit-tests --iterations 500 --exit-after-n-crashes-or-timeouts 1 imported/w3c/web-platform-tests/html/semantics/document-metadata/the-style-element/style_media.html --debug
Comment 4 Chris Dumez 2021-09-03 11:57:54 PDT
I tried to fix this in r281964.
Comment 5 Chris Dumez 2021-09-03 11:59:21 PDT
(In reply to Chris Dumez from comment #4)
> I tried to fix this in r281964.

Last crash seems to be r281871 so my fix in r281964 may have done the trick. Time will tell.
Comment 6 Chris Dumez 2021-09-03 12:02:12 PDT

*** This bug has been marked as a duplicate of bug 229769 ***
Comment 7 Chris Dumez 2021-09-03 12:03:01 PDT
My fix was speculative so please re-open if you still see this happening on the bots on a build after r281964.