Bug 229751 - PerformanceNavigationTiming should be instantiated before scripts run then updated when response finishes
Summary: PerformanceNavigationTiming should be instantiated before scripts run then up...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alex Christensen
URL:
Keywords: InRadar
: 229657 229774 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-31 23:35 PDT by Alex Christensen
Modified: 2021-11-06 05:28 PDT (History)
9 users (show)

See Also:


Attachments
Patch (13.83 KB, patch)
2021-08-31 23:41 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (14.32 KB, patch)
2021-09-01 10:28 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (1.46 KB, patch)
2021-09-01 14:37 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2021-08-31 23:35:56 PDT
PerformanceNavigationTiming should be instantiated before scripts run then updated when response finishes
Comment 1 Alex Christensen 2021-08-31 23:41:41 PDT
Created attachment 436996 [details]
Patch
Comment 2 EWS Watchlist 2021-08-31 23:42:55 PDT
This patch modifies the imported WPT tests. Please ensure that any changes on the tests (not coming from a WPT import) are exported to WPT. Please see https://trac.webkit.org/wiki/WPTExportProcess
Comment 3 Alex Christensen 2021-08-31 23:56:01 PDT
PR to wpt at https://github.com/web-platform-tests/wpt/pull/30280
Comment 4 Alex Christensen 2021-09-01 10:28:48 PDT
Created attachment 437041 [details]
Patch
Comment 5 EWS 2021-09-01 10:57:04 PDT
Committed r281860 (241190@main): <https://commits.webkit.org/241190@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 437041 [details].
Comment 6 Radar WebKit Bug Importer 2021-09-01 10:58:20 PDT
<rdar://problem/82636495>
Comment 7 Fujii Hironori 2021-09-01 12:52:42 PDT
*** Bug 229657 has been marked as a duplicate of this bug. ***
Comment 8 Alex Christensen 2021-09-01 14:36:59 PDT
Reopening to attach new patch.
Comment 9 Alex Christensen 2021-09-01 14:37:01 PDT
Created attachment 437069 [details]
Patch
Comment 10 Alex Christensen 2021-09-01 15:42:09 PDT
*** Bug 229774 has been marked as a duplicate of this bug. ***
Comment 11 EWS 2021-09-01 15:49:51 PDT
Committed r281884 (241214@main): <https://commits.webkit.org/241214@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 437069 [details].
Comment 12 Eric Hutchison 2021-09-02 10:13:20 PDT
Issue not resolved by changes in r281884.
Comment 13 Alex Christensen 2021-09-02 10:23:42 PDT
r281934