Bug 229516 - [Mac wk2 Release] imported/w3c/web-platform-tests/resource-timing/status-codes-create-entry.html is a flaky failure
Summary: [Mac wk2 Release] imported/w3c/web-platform-tests/resource-timing/status-code...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-08-25 14:13 PDT by Eric Hutchison
Modified: 2021-09-14 17:31 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Hutchison 2021-08-25 14:13:42 PDT
imported/w3c/web-platform-tests/resource-timing/status-codes-create-entry.html

is a flaky failure on Mac wk2 (BigSur, Monterey)

History: imported/w3c/web-platform-tests/resource-timing/status-codes-create-entry.html

Results: https://build.webkit.org/results/Apple-BigSur-Release-AppleSilicon-WK2-Tests/r281326%20(3332)/results.html

Diff:
--- /Volumes/Data/worker/bigsur-release-applesilicon-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/resource-timing/status-codes-create-entry-expected.txt
+++ /Volumes/Data/worker/bigsur-release-applesilicon-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/resource-timing/status-codes-create-entry-actual.txt
@@ -1,4 +1,4 @@
 
 
-PASS Make sure all status codes are reported
+FAIL Make sure all status codes are reported assert_greater_than: http://localhost:8800/resources/testharness.js expected a number greater than 0 but got 0
Comment 1 Radar WebKit Bug Importer 2021-08-25 14:15:09 PDT
<rdar://problem/82357467>
Comment 2 Eric Hutchison 2021-08-25 14:18:44 PDT
Updated test expectations at https://trac.webkit.org/changeset/281585/webkit.
Comment 3 Radar WebKit Bug Importer 2021-08-25 14:19:03 PDT
<rdar://problem/82357639>
Comment 4 Eric Hutchison 2021-09-13 16:15:21 PDT
Reproduced on r282352 using run-webkit-tests --release --force -f --iterations 1000 --exit-after-n-failures 2 --clobber-old-results -f --force --iterations 1000 --exit-after-n-failures 1 --clobber-old-results imported/w3c/web-platform-tests/resource-timing/status-codes-create-entry.html.
Comment 5 Eric Hutchison 2021-09-14 17:31:37 PDT
Unable to reproduce test results locally and issue has not occurred for 4 weeks. Removed test expectations: https://trac.webkit.org/changeset/282428/webkit.