Bug 228891 - Vertical scroll with mouse wheel in horizontal scroller fails to propagate to the document
Summary: Vertical scroll with mouse wheel in horizontal scroller fails to propagate to...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 229390 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-06 21:37 PDT by Simon Fraser (smfr)
Modified: 2021-08-25 13:26 PDT (History)
11 users (show)

See Also:


Attachments
Patch (11.10 KB, patch)
2021-08-06 21:44 PDT, Simon Fraser (smfr)
koivisto: review+
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
Patch (13.50 KB, patch)
2021-08-09 13:38 PDT, Simon Fraser (smfr)
ews-feeder: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2021-08-06 21:37:18 PDT
Vertical scroll with mouse wheel in horizontal scroller fails to propagate to the document
Comment 1 Simon Fraser (smfr) 2021-08-06 21:44:53 PDT
Created attachment 435115 [details]
Patch
Comment 2 Simon Fraser (smfr) 2021-08-06 21:44:57 PDT
<rdar://problem/81640239>
Comment 3 Simon Fraser (smfr) 2021-08-07 11:14:14 PDT
The test failure is real, but only occurs with async overflow scrolling disabled.
Comment 4 Simon Fraser (smfr) 2021-08-09 13:38:32 PDT
Created attachment 435207 [details]
Patch
Comment 5 EWS 2021-08-09 16:41:36 PDT
Committed r280807 (240377@main): <https://commits.webkit.org/240377@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 435207 [details].
Comment 6 Simon Fraser (smfr) 2021-08-25 13:26:00 PDT
*** Bug 229390 has been marked as a duplicate of this bug. ***