Bug 227984 - [css-grid] Images as grid items should use the overridingLogicalHeight when defined to compute the logical width
Summary: [css-grid] Images as grid items should use the overridingLogicalHeight when d...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zsun
URL:
Keywords: InRadar
: 227583 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-15 02:18 PDT by zsun
Modified: 2021-07-20 04:56 PDT (History)
12 users (show)

See Also:


Attachments
Patch (12.32 KB, patch)
2021-07-15 02:41 PDT, zsun
no flags Details | Formatted Diff | Diff
Patch (12.12 KB, patch)
2021-07-19 02:17 PDT, zsun
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description zsun 2021-07-15 02:18:59 PDT
RenderReplaced as grid items should use the overridingLogicalHeight when defined to compute the logical width.
Comment 1 zsun 2021-07-15 02:41:24 PDT
Created attachment 433570 [details]
Patch
Comment 2 Javier Fernandez 2021-07-17 02:59:35 PDT
Comment on attachment 433570 [details]
Patch

r=me
Comment 3 EWS 2021-07-19 01:44:56 PDT
Tools/Scripts/svn-apply failed to apply attachment 433570 [details] to trunk.
Please resolve the conflicts and upload a new patch.
Comment 4 zsun 2021-07-19 02:17:34 PDT
Created attachment 433778 [details]
Patch
Comment 5 EWS 2021-07-19 07:25:45 PDT
Committed r280024 (239766@main): <https://commits.webkit.org/239766@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 433778 [details].
Comment 6 Radar WebKit Bug Importer 2021-07-19 07:26:20 PDT
<rdar://problem/80782877>
Comment 7 zsun 2021-07-20 04:56:29 PDT
*** Bug 227583 has been marked as a duplicate of this bug. ***