Bug 227036 - REGRESSION(Monterey): TCC prompt on opening few websites using WKWebView on macOS 12.0
Summary: REGRESSION(Monterey): TCC prompt on opening few websites using WKWebView on m...
Status: RESOLVED DUPLICATE of bug 229238
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: WebKit Local Build
Hardware: Mac (Apple Silicon) Other
: P2 Normal
Assignee: Nobody
Keywords: InRadar
Depends on:
Reported: 2021-06-15 11:44 PDT by Dinesh Kumar Vyas
Modified: 2021-08-20 08:40 PDT (History)
6 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Dinesh Kumar Vyas 2021-06-15 11:44:12 PDT
WKWebView (latest WebKit 612.1.20) asking for Microphone access permission (TCC prompt) on first run (just after navigation commit) on macOS 12.0?
Tested several times by clearing privacy settings tccutil reset Microphone.

But when I tried on google.com, apple.com, there were no prompt.
And when I tested same on macOS 11.0, there was no prompt and everything was normal as expected.

How to reproduce -

Create a small macOS app with WKWebView (MiniBrowser can also be used) and try to load any website from bellow -

or bellow sites:
and even when I open custom url scheme
Comment 1 Radar WebKit Bug Importer 2021-06-15 11:57:37 PDT
Comment 2 youenn fablet 2021-08-06 01:32:35 PDT
I tried with MiniBrowser and was not able to repro.
Normally, WebKit will only trigger a prompt in case the page calls getUserMedia.

Would you be able to take a sysdiagnose while reproducing the error and noting the time of reproduction, then send it privately to me (youenn@apple.com)?
Comment 3 Jer Noble 2021-08-20 08:40:45 PDT
This was fixed by bug #229238.

*** This bug has been marked as a duplicate of bug 229238 ***