Bug 226084 - Accessibility caption styles does not always reflect the selection
Summary: Accessibility caption styles does not always reflect the selection
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Per Arne Vollan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-05-21 07:51 PDT by Per Arne Vollan
Modified: 2021-05-21 12:04 PDT (History)
9 users (show)

See Also:


Attachments
Patch (10.32 KB, patch)
2021-05-21 08:01 PDT, Per Arne Vollan
no flags Details | Formatted Diff | Diff
Patch (10.30 KB, patch)
2021-05-21 10:41 PDT, Per Arne Vollan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Per Arne Vollan 2021-05-21 07:51:03 PDT
This is caused by a race between pushing the caption preference value to the WebContent process and receiving the notification in that process.
Comment 1 Per Arne Vollan 2021-05-21 07:51:21 PDT
<rdar://75426845>
Comment 2 Per Arne Vollan 2021-05-21 08:01:26 PDT
Created attachment 429289 [details]
Patch
Comment 3 chris fleizach 2021-05-21 10:30:54 PDT
Comment on attachment 429289 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=429289&action=review

> Source/WebKit/WebProcess/cocoa/WebProcessCocoa.mm:1107
> +        return;

we probably don't need a return here. the other if blocks don't have it
Comment 4 Per Arne Vollan 2021-05-21 10:39:10 PDT
(In reply to chris fleizach from comment #3)
> Comment on attachment 429289 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=429289&action=review
> 
> > Source/WebKit/WebProcess/cocoa/WebProcessCocoa.mm:1107
> > +        return;
> 
> we probably don't need a return here. the other if blocks don't have it

Will fix.

Thanks for reviewing!
Comment 5 Per Arne Vollan 2021-05-21 10:41:41 PDT
Created attachment 429310 [details]
Patch
Comment 6 EWS 2021-05-21 12:04:47 PDT
Committed r277874 (238012@main): <https://commits.webkit.org/238012@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 429310 [details].