Bug 225438 - Re-import css/css-color & css/css-color-adjust WPT
Summary: Re-import css/css-color & css/css-color-adjust WPT
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tim Nguyen (:ntim)
URL:
Keywords: InRadar
: 220928 (view as bug list)
Depends on:
Blocks: update-css-wpt
  Show dependency treegraph
 
Reported: 2021-05-06 01:05 PDT by Tim Nguyen (:ntim)
Modified: 2021-05-06 02:45 PDT (History)
5 users (show)

See Also:


Attachments
Patch (24.19 KB, patch)
2021-05-06 01:20 PDT, Tim Nguyen (:ntim)
no flags Details | Formatted Diff | Diff
Patch (25.05 KB, patch)
2021-05-06 01:56 PDT, Tim Nguyen (:ntim)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Nguyen (:ntim) 2021-05-06 01:05:09 PDT
Changes not staged for commit:
  (use "git add/rm <file>..." to update what will be committed)
  (use "git restore <file>..." to discard changes in working directory)
	modified:   LayoutTests/imported/w3c/resources/import-expectations.json
	modified:   LayoutTests/imported/w3c/web-platform-tests/css/css-color/color-function-parsing.html
	deleted:    LayoutTests/imported/w3c/web-platform-tests/css/css-color/predefined-014-expected.html
	deleted:    LayoutTests/imported/w3c/web-platform-tests/css/css-color/predefined-014.html
	deleted:    LayoutTests/imported/w3c/web-platform-tests/css/css-color/predefined-015-expected.html
	deleted:    LayoutTests/imported/w3c/web-platform-tests/css/css-color/predefined-015.html
	modified:   LayoutTests/imported/w3c/web-platform-tests/css/css-color/w3c-import.log

Untracked files:
  (use "git add <file>..." to include in what will be committed)
	LayoutTests/imported/w3c/web-platform-tests/css/css-color/color-mix-basic-001.tentative.html
Comment 1 Tim Nguyen (:ntim) 2021-05-06 01:10:46 PDT
Let's also do css-color-adjust:

Changes not staged for commit:
  (use "git add <file>..." to update what will be committed)
  (use "git restore <file>..." to discard changes in working directory)
	modified:   LayoutTests/imported/w3c/resources/import-expectations.json
	modified:   LayoutTests/imported/w3c/resources/resource-files.json
	modified:   LayoutTests/imported/w3c/web-platform-tests/css/css-color-adjust/rendering/dark-color-scheme/w3c-import.log
	modified:   LayoutTests/imported/w3c/web-platform-tests/css/css-color-adjust/w3c-import.log

Untracked files:
  (use "git add <file>..." to include in what will be committed)
	LayoutTests/imported/w3c/web-platform-tests/css/css-color-adjust/META.yml
	LayoutTests/imported/w3c/web-platform-tests/css/css-color-adjust/rendering/dark-color-scheme/color-scheme-iframe-background-mismatch-opaque-cross-origin.sub-expected.html
	LayoutTests/imported/w3c/web-platform-tests/css/css-color-adjust/rendering/dark-color-scheme/color-scheme-iframe-background-mismatch-opaque-cross-origin.sub.html
	LayoutTests/imported/w3c/web-platform-tests/css/css-color-adjust/rendering/dark-color-scheme/color-scheme-system-colors.html
Comment 2 Tim Nguyen (:ntim) 2021-05-06 01:20:16 PDT
*** Bug 220928 has been marked as a duplicate of this bug. ***
Comment 3 Tim Nguyen (:ntim) 2021-05-06 01:20:55 PDT
Created attachment 427857 [details]
Patch
Comment 4 Tim Nguyen (:ntim) 2021-05-06 01:56:56 PDT
Created attachment 427860 [details]
Patch
Comment 5 youenn fablet 2021-05-06 02:27:32 PDT
Comment on attachment 427860 [details]
Patch

r=me once bots are happy
Comment 6 EWS 2021-05-06 02:44:44 PDT
Committed r277077 (237380@main): <https://commits.webkit.org/237380@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 427860 [details].
Comment 7 Radar WebKit Bug Importer 2021-05-06 02:45:15 PDT
<rdar://problem/77599257>