Bug 224130 - REGRESSION (r275358): [ iOS wk2 ] media/modern-media-controls/ios-inline-media-controls/ios-inline-media-dropping-controls.html is a constant text failure
Summary: REGRESSION (r275358): [ iOS wk2 ] media/modern-media-controls/ios-inline-medi...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-04-02 13:47 PDT by Robert Jenner
Modified: 2021-04-05 17:04 PDT (History)
9 users (show)

See Also:


Attachments
Patch (3.31 KB, patch)
2021-04-02 14:48 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Jenner 2021-04-02 13:47:20 PDT
media/modern-media-controls/ios-inline-media-controls/ios-inline-media-dropping-controls.html

is a constant text failure in iOS Simulator wk2. 

HISTORY URL:
https://results.webkit.org/?suite=layout-tests&test=media%2Fmodern-media-controls%2Fios-inline-media-controls%2Fios-inline-media-dropping-controls.html

TEXT DIFF:
 PASS ready() became true
 
 TracksButton was dropped at 681.
-PiPButton was dropped at 681.
+PiPButton was dropped at 680.
 SkipForwardButton was dropped at 453.
 SkipBackButton was dropped at 424.
 MuteButton was dropped at 395.
Comment 1 Robert Jenner 2021-04-02 13:49:40 PDT
It looks like the test was modified here:

https://trac.webkit.org/changeset/275358/webkit

And it started constantly failing after that. Working on reproducing the failure.
Comment 2 Robert Jenner 2021-04-02 14:01:07 PDT
Reproduced failure at iOS 14 Simulator release ToT using the following test:

run-webkit-tests --ios-simulator --iterations 100 -f media/modern-media-controls/ios-inline-media-controls/ios-inline-media-dropping-controls.html

The failure became unreproducible at ToT when checking out r275357 locally. 

The failure started to reproduce again at ToT when checking out r275358 locally.

It appears that this was caused by r275358:
https://trac.webkit.org/changeset/275358/webkit
Comment 3 Radar WebKit Bug Importer 2021-04-02 14:02:21 PDT
<rdar://problem/76164289>
Comment 4 Devin Rousso 2021-04-02 14:48:12 PDT
Created attachment 425056 [details]
Patch
Comment 5 Devin Rousso 2021-04-02 18:28:34 PDT
Comment on attachment 425056 [details]
Patch

test failure is not related to the tests i'm fixing
Comment 6 EWS 2021-04-05 17:04:31 PDT
Committed r275456: <https://commits.webkit.org/r275456>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 425056 [details].