Bug 224064 - [GTK] Layout test media/video-orientation-canvas.html fails
Summary: [GTK] Layout test media/video-orientation-canvas.html fails
Status: RESOLVED DUPLICATE of bug 223850
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-01 12:09 PDT by Carlos Alberto Lopez Perez
Modified: 2021-04-01 13:47 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2021-04-01 12:09:01 PDT
The layout test fails on GTK (and likely on WPE as well, but we are currently skipping media tests on WPE) with this:

--- /home/igalia/clopez/webkit/webkit-flatpak/layout-test-results/media/video-orientation-canvas-expected.txt
+++ /home/igalia/clopez/webkit/webkit-flatpak/layout-test-results/media/video-orientation-canvas-actual.txt
@@ -1,6 +1,6 @@
 
-EXPECTED (context.getImageData(88, 115, 1, 1).data == [208,0,0,255] with tolerance 5 OK
+EXPECTED (context.getImageData(88, 115, 1, 1).data == [208,0,0,255] with tolerance 5, OBSERVED '[0,0,0,255]' FAIL
 EXPECTED (context.getImageData(237, 88, 1, 1).data == [208,0,0,255] with tolerance 5 OK
-EXPECTED (context.getImageData(200, 237, 1, 1).data == [208,0,0,255] with tolerance 5 OK
+EXPECTED (context.getImageData(200, 237, 1, 1).data == [208,0,0,255] with tolerance 5, OBSERVED '[0,0,0,255]' FAIL
 END OF TEST
 
The failure happens since r274076
Comment 1 Carlos Alberto Lopez Perez 2021-04-01 12:10:56 PDT
Ok.. the failure just happens because r274076 removed the expected failure from media/video-orientation-canvas.html LayoutTests/platform/wk2/TestExpectations 

So this is not a regression
Comment 2 Philippe Normand 2021-04-01 12:44:24 PDT
Maybe review https://bugs.webkit.org/show_bug.cgi?id=223850 ? :)
Comment 3 Carlos Alberto Lopez Perez 2021-04-01 13:47:23 PDT
(In reply to Philippe Normand from comment #2)
> Maybe review https://bugs.webkit.org/show_bug.cgi?id=223850 ? :)

Ups.. i missed that

*** This bug has been marked as a duplicate of bug 223850 ***