Bug 223673 - [Catalina WK2] 5 media/modern-media-controls/tracks-support tests consistently timing out
Summary: [Catalina WK2] 5 media/modern-media-controls/tracks-support tests consistentl...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-03-23 21:26 PDT by Ryan Haddad
Modified: 2021-03-30 21:20 PDT (History)
11 users (show)

See Also:


Attachments
[Patch] test for EWS to tell me what `contextmenu` is (5.04 KB, patch)
2021-03-24 15:56 PDT, Devin Rousso
drousso: review-
drousso: commit-queue-
Details | Formatted Diff | Diff
[Patch] test for EWS to tell me what `contextmenu` is (after removing test expectations) (6.03 KB, patch)
2021-03-24 15:57 PDT, Devin Rousso
drousso: commit-queue-
Details | Formatted Diff | Diff
[Patch] test for EWS to tell me what `contextmenu` is (after removing test expectations) (6.03 KB, patch)
2021-03-24 16:08 PDT, Devin Rousso
drousso: commit-queue-
Details | Formatted Diff | Diff
Patch (6.72 KB, patch)
2021-03-30 16:44 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2021-03-23 21:26:29 PDT
The following tests have been consistently timing out on Catalina WK2 bots since they were added/enabled with https://trac.webkit.org/changeset/274521/webkit

media/modern-media-controls/tracks-support/auto-text-track.html
media/modern-media-controls/tracks-support/click-track-in-contextmenu.html
media/modern-media-controls/tracks-support/hidden-tracks.html
media/modern-media-controls/tracks-support/off-text-track.html
media/modern-media-controls/tracks-support/text-track-selected-via-media-api.html

https://results.webkit.org/?suite=layout-tests&suite=layout-tests&suite=layout-tests&suite=layout-tests&suite=layout-tests&test=media%2Fmodern-media-controls%2Ftracks-support%2Fauto-text-track.html&test=media%2Fmodern-media-controls%2Ftracks-support%2Fclick-track-in-contextmenu.html&test=media%2Fmodern-media-controls%2Ftracks-support%2Fhidden-tracks.html&test=media%2Fmodern-media-controls%2Ftracks-support%2Foff-text-track.html&test=media%2Fmodern-media-controls%2Ftracks-support%2Ftext-track-selected-via-media-api.html
Comment 1 Radar WebKit Bug Importer 2021-03-23 21:26:37 PDT
<rdar://problem/75769577>
Comment 2 Ryan Haddad 2021-03-23 21:28:03 PDT
Devin, are these tests supposed to work on Catalina or should they be skipped?
Comment 3 Devin Rousso 2021-03-24 15:10:38 PDT
Yeah I think these should work in Catalina.  I wonder why they're working in Big Sur and not Catalina 🤔

I do see
```
CONSOLE MESSAGE: Unhandled Promise Rejection: TypeError: undefined is not an object (evaluating 'subtitlesMenu.children')
```
in the output, so perhaps adding a
```
-if (subtitlesMenu.children?.length) {
+if (subtitlesMenu?.children?.length) {
```
would fix this?
Comment 4 Devin Rousso 2021-03-24 15:56:13 PDT
Created attachment 424194 [details]
[Patch] test for EWS to tell me what `contextmenu` is
Comment 5 Devin Rousso 2021-03-24 15:57:54 PDT
Created attachment 424195 [details]
[Patch] test for EWS to tell me what `contextmenu` is (after removing test expectations)
Comment 6 Devin Rousso 2021-03-24 16:08:10 PDT
Created attachment 424197 [details]
[Patch] test for EWS to tell me what `contextmenu` is (after removing test expectations)
Comment 7 Devin Rousso 2021-03-24 21:22:09 PDT
This testing patch that I've uploaded suggests that these tests are passing on mac-wk2 (which I believe is Catalina), so I'm not really sure what to do here :/
Comment 8 Truitt Savell 2021-03-25 16:00:46 PDT
From looking around this issue seems to only reproduce on the Macmini8,1s on Catalina. locally I can only get a timeout running in wk1 which these tests are not ran on in production.
Comment 9 Devin Rousso 2021-03-30 16:44:13 PDT
Created attachment 424715 [details]
Patch
Comment 10 EWS 2021-03-30 21:20:12 PDT
Committed r275265: <https://commits.webkit.org/r275265>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 424715 [details].