Bug 22182 - scrollbars like in youtube's "related" box don't work as expected
Summary: scrollbars like in youtube's "related" box don't work as expected
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Dave Hyatt
URL: http://www.youtube.com/watch?v=-YUxbD...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-11 12:17 PST by Alexander Kempgen
Modified: 2008-11-11 12:44 PST (History)
0 users

See Also:


Attachments
Patch (2.15 KB, patch)
2008-11-11 12:33 PST, Dave Hyatt
adele: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kempgen 2008-11-11 12:17:33 PST
1) the up/down arrows don't scroll in small steps, but instead jump to the beginning/end of the list.

2) the scrollbar handle does not center on the vertical position of the mouse pointer when grabbed, but is below it instead.
Comment 1 Dave Hyatt 2008-11-11 12:18:53 PST
I cannot reproduce this.  They work just fine for me.
Comment 2 Dave Hyatt 2008-11-11 12:24:47 PST
WHen click is set to "Jump to here" I can repro.

Comment 3 Dave Hyatt 2008-11-11 12:33:36 PST
Created attachment 25049 [details]
Patch
Comment 4 Dave Hyatt 2008-11-11 12:44:23 PST
Fixed in r38312.