Bug 220459 - Support unprefixed :autofill pseudo-class.
Summary: Support unprefixed :autofill pseudo-class.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Emilio Cobos Álvarez (:emilio)
URL:
Keywords: InRadar, WebExposed
Depends on: 225851
Blocks:
  Show dependency treegraph
 
Reported: 2021-01-08 02:39 PST by Emilio Cobos Álvarez (:emilio)
Modified: 2021-07-01 02:03 PDT (History)
15 users (show)

See Also:


Attachments
Patch (2.23 KB, patch)
2021-05-16 02:34 PDT, Emilio Cobos Álvarez (:emilio)
no flags Details | Formatted Diff | Diff
Patch (3.53 KB, patch)
2021-05-16 03:08 PDT, Emilio Cobos Álvarez (:emilio)
no flags Details | Formatted Diff | Diff
Patch (11.93 KB, patch)
2021-06-08 12:18 PDT, Emilio Cobos Álvarez (:emilio)
no flags Details | Formatted Diff | Diff
Patch (3.52 KB, patch)
2021-06-24 08:12 PDT, Emilio Cobos Álvarez (:emilio)
no flags Details | Formatted Diff | Diff
Patch (5.12 KB, patch)
2021-06-24 16:44 PDT, Emilio Cobos Álvarez (:emilio)
no flags Details | Formatted Diff | Diff
Patch (6.79 KB, patch)
2021-06-24 17:27 PDT, Emilio Cobos Álvarez (:emilio)
no flags Details | Formatted Diff | Diff
Patch for landing (7.65 KB, patch)
2021-07-01 00:49 PDT, Emilio Cobos Álvarez (:emilio)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Radar WebKit Bug Importer 2021-01-15 02:40:13 PST
<rdar://problem/73242004>
Comment 2 Emilio Cobos Álvarez (:emilio) 2021-05-16 02:34:15 PDT
Created attachment 428780 [details]
Patch
Comment 3 Emilio Cobos Álvarez (:emilio) 2021-05-16 02:35:42 PDT
Does anybody know what's the issue I hit when importing the tests? Should I file a bug for that?

I of course confirmed my patch passes http://wpt.live/html/semantics/selectors/pseudo-classes/autofill.html, but...
Comment 4 Emilio Cobos Álvarez (:emilio) 2021-05-16 02:56:12 PDT
Err, forgot the -t flag, and it was defaulting to a super-old revision. Will fix.
Comment 5 Emilio Cobos Álvarez (:emilio) 2021-05-16 03:08:08 PDT
Created attachment 428782 [details]
Patch
Comment 6 Emilio Cobos Álvarez (:emilio) 2021-06-08 12:18:34 PDT
Created attachment 430872 [details]
Patch
Comment 7 Emilio Cobos Álvarez (:emilio) 2021-06-08 12:21:37 PDT
Comment on attachment 430872 [details]
Patch

Err, webkit-patch got confused when not submitting HEAD, looks like... This should've gone to the dependent bug.
Comment 8 Emilio Cobos Álvarez (:emilio) 2021-06-24 08:12:09 PDT
Created attachment 432164 [details]
Patch
Comment 9 Emilio Cobos Álvarez (:emilio) 2021-06-24 16:44:37 PDT
Created attachment 432221 [details]
Patch
Comment 10 Emilio Cobos Álvarez (:emilio) 2021-06-24 17:27:39 PDT
Created attachment 432224 [details]
Patch
Comment 11 Emilio Cobos Álvarez (:emilio) 2021-06-24 21:56:16 PDT
Alright, ews is green now.
Comment 12 Tim Nguyen (:ntim) 2021-06-30 03:00:45 PDT
Small nit: I think some changelogs need to be regenerated
Comment 13 Emilio Cobos Álvarez (:emilio) 2021-07-01 00:49:34 PDT
Created attachment 432664 [details]
Patch for landing
Comment 14 EWS 2021-07-01 02:03:47 PDT
Committed r279457 (239313@main): <https://commits.webkit.org/239313@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 432664 [details].