Bug 21935 - No support for load method to load XML document
Summary: No support for load method to load XML document
Status: RESOLVED DUPLICATE of bug 9063
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 525.x (Safari 3.1)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-28 14:36 PDT by Anantha Keesara
Modified: 2008-10-29 10:43 PDT (History)
2 users (show)

See Also:


Attachments
HTML file (569 bytes, text/html)
2008-10-28 14:39 PDT, Anantha Keesara
no flags Details
XML File (149 bytes, application/xml)
2008-10-28 14:40 PDT, Anantha Keesara
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anantha Keesara 2008-10-28 14:36:58 PDT
What steps will reproduce the problem?
1. Load the attached testcase or go to the link given below

What is the expected output? 
Google

What do you see instead?
An error that the object has no load method

IE7, FF3: ok
Safari4(526), Chrome: not ok
Comment 1 Anantha Keesara 2008-10-28 14:39:47 PDT
Created attachment 24731 [details]
HTML file
Comment 2 Anantha Keesara 2008-10-28 14:40:27 PDT
Created attachment 24732 [details]
XML File
Comment 3 Eric Seidel (no email) 2008-10-28 14:46:05 PDT
https://developer.mozilla.org/En/DOM/Document.load is mozilla's documentation.  If author's used XHR it would work in both moz an webkit.

DOM 3 Load Save doesn't even include this interface anymore:
http://www.w3.org/TR/DOM-Level-3-LS/load-save.html

So I don't think we ever plan to support this.  Certainly it would be possible to implement this with a synchronous XHR.
Comment 4 Alexey Proskuryakov 2008-10-29 04:02:12 PDT
There seems to be much site compatibility trouble because of Document.load (see e.g. bug 9063, bug 19914), so we may end up having to implement it.
Comment 5 Eric Seidel (no email) 2008-10-29 10:43:09 PDT
Re-opening to dupe against bug 9063.
Comment 6 Eric Seidel (no email) 2008-10-29 10:43:17 PDT

*** This bug has been marked as a duplicate of 9063 ***