Bug 215278 - [ iOS wk2 Debug ] imported/w3c/web-platform-tests/html/semantics/scripting-1/the-script-element/moving-between-documents/before-prepare-iframe-parse-error-external-module.html is a flaky failure
Summary: [ iOS wk2 Debug ] imported/w3c/web-platform-tests/html/semantics/scripting-1/...
Status: RESOLVED DUPLICATE of bug 217931
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-08-07 10:48 PDT by Hector Lopez
Modified: 2020-12-08 13:43 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hector Lopez 2020-08-07 10:48:36 PDT
imported/w3c/web-platform-tests/html/semantics/scripting-1/the-script-element/moving-between-documents/before-prepare-iframe-parse-error-external-module.html

This test is a flaky failure on iOS wk2 Debug according to history. First occurrence of failure at r264038. This is fairly soon after introduction

History:
https://bugs.webkit.org/enter_bug.cgi?product=WebKit

Diff:
--- /Volumes/Data/slave/ios-simulator-13-debug-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/html/semantics/scripting-1/the-script-element/moving-between-documents/before-prepare-iframe-parse-error-external-module-expected.txt
+++ /Volumes/Data/slave/ios-simulator-13-debug-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/html/semantics/scripting-1/the-script-element/moving-between-documents/before-prepare-iframe-parse-error-external-module-actual.txt
@@ -1,9 +1,10 @@
 CONSOLE MESSAGE: SyntaxError: Left side of assignment is not a reference.
+CONSOLE MESSAGE: ReferenceError: Can't find variable: scriptOnError
  
 
 PASS Sanity check around top-level Window 
 PASS Eval: Move parse-error external module script to iframe before-prepare 
 PASS <script> load: Move parse-error external module script to iframe before-prepare 
-FAIL <script> error: Move parse-error external module script to iframe before-prepare assert_unreached: Script error evennt fired unexpectedly Reached unreachable code
+PASS <script> error: Move parse-error external module script to iframe before-prepare 
 PASS window error: Move parse-error external module script to iframe before-prepare
Comment 1 Radar WebKit Bug Importer 2020-08-07 10:49:00 PDT
<rdar://problem/66689424>
Comment 2 Hector Lopez 2020-08-07 11:10:42 PDT
Test expectation while investigated:

https://trac.webkit.org/changeset/265381/webkit
Comment 3 Hector Lopez 2020-08-07 11:36:00 PDT
Correction made to expectation:

https://trac.webkit.org/changeset/265385/webkit
Comment 4 Sam Sneddon [:gsnedders] 2020-12-08 13:43:45 PST

*** This bug has been marked as a duplicate of bug 217931 ***