Bug 214685 - REGRESSION: [ iOS wk2 debug ] imported/w3c/web-platform-tests/html/semantics/scripting-1/the-script-element/moving-between-documents/before-prepare-createHTMLDocument-fetch-error-external-classic.html is a flaky failure
Summary: REGRESSION: [ iOS wk2 debug ] imported/w3c/web-platform-tests/html/semantics/...
Status: RESOLVED DUPLICATE of bug 217931
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: iPhone / iPad Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-07-23 07:29 PDT by Karl Rackler
Modified: 2020-12-08 13:43 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Rackler 2020-07-23 07:29:53 PDT
Description:
imported/w3c/web-platform-tests/html/semantics/scripting-1/the-script-element/moving-between-documents/before-prepare-createHTMLDocument-fetch-error-external-classic.html

This started approximately 07/10/20 and is flaky failure happening rarely.  e.g. Every four to ten days, but once consecutive days.

History:
https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2Fhtml%2Fsemantics%2Fscripting-1%2Fthe-script-element%2Fmoving-between-documents%2Fbefore-prepare-createHTMLDocument-fetch-error-external-classic.html&platform=ios&limit=50000&style=debug

Diff:
--- /Volumes/Data/slave/ipados-simulator-13-debug-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/html/semantics/scripting-1/the-script-element/moving-between-documents/before-prepare-createHTMLDocument-fetch-error-external-classic-expected.txt
+++ /Volumes/Data/slave/ipados-simulator-13-debug-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/html/semantics/scripting-1/the-script-element/moving-between-documents/before-prepare-createHTMLDocument-fetch-error-external-classic-actual.txt
@@ -1,3 +1,4 @@
+CONSOLE MESSAGE: ReferenceError: Can't find variable: scriptOnError
  
 
 PASS Sanity check around top-level Window
Comment 1 Radar WebKit Bug Importer 2020-07-23 07:30:21 PDT
<rdar://problem/65990939>
Comment 2 Karl Rackler 2020-07-23 07:34:27 PDT
I have marked these tests as failing while this issue is investigated.
https://trac.webkit.org/changeset/264761/webkit
Comment 3 Ryan Haddad 2020-07-23 16:54:17 PDT
This test was just imported as part of http://trac.webkit.org/changeset/263987/webkit on 7/7/20, so it was probably flaky from the start.
Comment 4 Sam Sneddon [:gsnedders] 2020-12-08 13:43:28 PST

*** This bug has been marked as a duplicate of bug 217931 ***