RESOLVED FIXED Bug 214347
[css-grid] Rename SmallestTrackStart to ExplicitGridStart
https://bugs.webkit.org/show_bug.cgi?id=214347
Summary [css-grid] Rename SmallestTrackStart to ExplicitGridStart
Oriol Brufau
Reported 2020-07-15 05:08:39 PDT
The SmallestTrackStart method returns a signed int which is never positive, representing the smallest untranslated start among all grid items, clamped by 0 as a maximum. In practice, though, what we usually want is the index of the first explicit track/line among all tracks/lines, or equivalently, the number of leading implicit tracks/lines. That number is precisely minus the return value of SmallestTrackStart. Thus, in grid layout there were various std::abs() to invert the value. But it's a bit confusing to have an API which returns a non-positive integer, which then needs to be made non-negative. Therefore, we should rename SmallestTrackStart to ExplicitGridStart, and make it return an unsigned int. Chromium did this in https://crrev.com/777768
Attachments
Patch (10.86 KB, patch)
2020-07-15 05:17 PDT, Oriol Brufau
no flags
Oriol Brufau
Comment 1 2020-07-15 05:17:02 PDT
Manuel Rego Casasnovas
Comment 2 2020-07-15 05:54:37 PDT
Comment on attachment 404333 [details] Patch r=me, wait for green EWSs before landing.
EWS
Comment 3 2020-07-15 10:26:45 PDT
Committed r264403: <https://trac.webkit.org/changeset/264403> All reviewed patches have been landed. Closing bug and clearing flags on attachment 404333 [details].
Radar WebKit Bug Importer
Comment 4 2020-07-15 10:27:15 PDT
Note You need to log in before you can comment on or make changes to this bug.