Bug 213622 - Safari 14 - User Agent string shows incorrect OS version
Summary: Safari 14 - User Agent string shows incorrect OS version
Status: ASSIGNED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Conrad Shultz
URL:
Keywords:
: 219728 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-25 15:18 PDT by Jash Sayani
Modified: 2021-02-14 17:34 PST (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jash Sayani 2020-06-25 15:18:15 PDT
Safari 14 Dev Preview shows the userAgent string as "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_16)". It should say MacOS 11.
Comment 1 Alexey Proskuryakov 2020-12-10 15:41:36 PST
*** Bug 219728 has been marked as a duplicate of this bug. ***
Comment 2 Max G 2021-01-11 05:07:49 PST
Not even that!

Safari shows this user agent:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.3 Safari/605.1.15

Also on Silicon Macs it still shows "Intel"

Please fix this urgent bug because a lot of websites are broken because of that!
Comment 3 Max G 2021-01-11 05:09:05 PST
I Hope this bug will be fixed this year
Comment 4 Alexey Proskuryakov 2021-01-11 09:11:51 PST
> Also on Silicon Macs it still shows "Intel"

This aspect is intentional.

> Please fix this urgent bug because a lot of websites are broken because of that!

What are the websites that are broken because of 10_15_6? We are aware of websites that would be broken but exposing version 11, but not vice versa.
Comment 5 Max G 2021-01-11 09:29:25 PST
That is really sad because this intentional step break the sense of the user agent more than just using the user agent regularly.

A lot of websites checking the user agent if the browser supports vp9.(or other system relative features)

On IOS it works perfect (on iOS 13 you get the message with the to old system)
But on Safari on macOS the app still detects an incompatible System version.

Hh but wait I use the desktop user agent as a default on my iOS device does that mean that this confuses a lot of websites?
Yep a lot of websites still tell me incompatibility because of that.

Google Chrome as example use the user agent as intending and there are no problems at all.

If The User agent is 10_16 I can totally understand that but 10_15_6 is completely unreasonable and make the development much harder.

This is the perfect proof that the user agent is the biggest bulls*** and I hope that chrome gets through with there new User Hint System! (and Safari too)

So if you don't use the user agent as intended please at least change it to 10_16 so that developers doesn't feel fooled and need to rewrite a lot of things (which a lot of developers just doesn't do)
Comment 6 Alexey Proskuryakov 2021-01-11 10:02:45 PST
I recommend reaching out to webkit-help to discuss how to detect VP9 support. There may be a better way than checking OS version.
Comment 7 karl 2021-02-14 17:34:08 PST
Max G, some websites are breaking because of macOS 11 string. So it's a two edges sword. 

Would you be kind to share which websites are breaking that would be super helpful to assess the Web compatibility issue surface?

Note that you can check some of the followup issues

WebKit (Safari)
https://bugs.webkit.org/show_bug.cgi?id=216593 
https://bugs.webkit.org/show_bug.cgi?id=217364

Gecko (Firefox)
https://bugzilla.mozilla.org/show_bug.cgi?id=1679929
https://bugzilla.mozilla.org/show_bug.cgi?id=1680516
https://bugzilla.mozilla.org/show_bug.cgi?id=1682238

Blink (Chrome, Edge)
https://bugs.chromium.org/p/chromium/issues/detail?id=1175225
https://groups.google.com/a/chromium.org/g/blink-dev/c/hAI4QoX6rEo/m/qQNPThr0AAAJ