Bug 211133 - REGRESSION(r260822): Broke media/track/track-in-band-metadata-display-order.html on Mac
Summary: REGRESSION(r260822): Broke media/track/track-in-band-metadata-display-order.h...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Philippe Normand
URL:
Keywords: InRadar
: 211132 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-28 09:40 PDT by Philippe Normand
Modified: 2020-04-28 11:58 PDT (History)
9 users (show)

See Also:


Attachments
Patch (1.81 KB, patch)
2020-04-28 09:47 PDT, Philippe Normand
no flags Details | Formatted Diff | Diff
Patch (2.27 KB, patch)
2020-04-28 10:53 PDT, Philippe Normand
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Normand 2020-04-28 09:40:44 PDT
,
Comment 1 Philippe Normand 2020-04-28 09:47:04 PDT
Created attachment 397847 [details]
Patch
Comment 2 Philippe Normand 2020-04-28 09:49:52 PDT
*** Bug 211132 has been marked as a duplicate of this bug. ***
Comment 3 Philippe Normand 2020-04-28 09:57:10 PDT
history:
https://results.webkit.org/?suite=layout-tests&test=media%2Ftrack%2Ftrack-in-band-metadata-display-order.html

Diff:
--- /Volumes/Data/slave/catalina-release-tests-wk1/build/layout-test-results/media/track/track-in-band-metadata-display-order-expected.txt
+++ /Volumes/Data/slave/catalina-release-tests-wk1/build/layout-test-results/media/track/track-in-band-metadata-display-order-actual.txt
@@ -15,7 +15,7 @@
 RUN(metadataTrack.addCue(new DataCue(2.25, video.duration, "second data cue")))
 RUN(video.currentTime = 3)
 EVENT(seeked)
-EXPECTED (textTrackDisplayElement(video, "display", 0).textContent == 'I am later') OK
-EXPECTED (textTrackDisplayElement(video, "display", 1).textContent == 'I am earlier') OK
+EXPECTED (textTrackDisplayElement(video, "display", 0).textContent == 'I am later'), OBSERVED 'I am later ::cue{background-color:rgba(0, 0, 0, 0) !important;color:#ffffff;font-family: "Helvetica";} ::-webkit-media-text-track-display-backdrop{background-color:rgba(0, 0, 0, 0.498) !important;padding: .4em !important;border-radius:8px !important;}' FAIL
+EXPECTED (textTrackDisplayElement(video, "display", 1).textContent == 'I am earlier'), OBSERVED 'I am earlier ::cue{background-color:rgba(0, 0, 0, 0) !important;color:#ffffff;font-family: "Helvetica";} ::-webkit-media-text-track-display-backdrop{background-color:rgba(0, 0, 0, 0.498) !important;padding: .4em !important;border-radius:8px !important;}' FAIL
 END OF TEST
[tag] [reply] [−] Comment 7
Comment 4 Philippe Normand 2020-04-28 09:58:47 PDT
Apololgies for not noticing this, because in GTK we had that test flagged already as failing/crash/pass ... See #198830
Comment 5 Philippe Normand 2020-04-28 10:39:14 PDT
Comment on attachment 397847 [details]
Patch

Forgot to rebaseline.
Comment 6 Philippe Normand 2020-04-28 10:53:29 PDT
Created attachment 397856 [details]
Patch
Comment 7 Philippe Normand 2020-04-28 10:54:51 PDT
I unflagged the test on GTK and checked it passes. Can't check on mac currently though.
Comment 8 EWS 2020-04-28 11:57:09 PDT
Committed r260835: <https://trac.webkit.org/changeset/260835>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 397856 [details].
Comment 9 Radar WebKit Bug Importer 2020-04-28 11:58:20 PDT
<rdar://problem/62534924>