Bug 21111 - Crash (no stack trace) when loading web page
Summary: Crash (no stack trace) when loading web page
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://paulstamatiou.com/2008/08/21/h...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-25 10:42 PDT by Steven Hollingsworth
Modified: 2008-09-27 15:30 PDT (History)
0 users

See Also:


Attachments
Crash Log (26.75 KB, text/plain)
2008-09-25 10:43 PDT, Steven Hollingsworth
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Hollingsworth 2008-09-25 10:42:51 PDT
When trying to load the web page (http://paulstamatiou.com/2008/08/21/how-to-live-the-cloud-life), WebKit instantly crashes.
Comment 1 Steven Hollingsworth 2008-09-25 10:43:19 PDT
Created attachment 23809 [details]
Crash Log

Crash log from resulting crash.
Comment 2 Steven Hollingsworth 2008-09-25 10:47:05 PDT
If the page does not cause WebKit to crash instantly, try clicking on one of the links to the right under the "Recently Popular" sidebar.
Comment 3 Mark Rowe (bdash) 2008-09-25 12:47:36 PDT
I cannot reproduce this in a debug build of r36901.  It may have been fixed already.
Comment 4 Alexey Proskuryakov 2008-09-26 01:04:40 PDT
I also cannot reproduce this with a local debug build. However, I'm on a pretty close revision, which suggests that the bug may be poorly reproducible, or somehow release-only.
Comment 5 Steven Hollingsworth 2008-09-27 15:30:09 PDT
I have no idea what originally caused this, but as of nightly r37006, everything seems to be fine.