Bug 210825 - REGRESSION(r260410) Frequent Network process crashes
Summary: REGRESSION(r260410) Frequent Network process crashes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks: 210533
  Show dependency treegraph
 
Reported: 2020-04-21 16:36 PDT by Chris Dumez
Modified: 2020-04-22 07:53 PDT (History)
4 users (show)

See Also:


Attachments
Patch (8.66 KB, patch)
2020-04-21 16:47 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2020-04-21 16:36:37 PDT
Frequent Network process crashes due to bad IPC:
Received an invalid message ‘NetworkProcessProxy::DidNegotiateModernTLS’ from the Networking process.
Comment 1 Chris Dumez 2020-04-21 16:47:00 PDT
Created attachment 397140 [details]
Patch
Comment 2 Chris Dumez 2020-04-21 16:51:57 PDT
<rdar://problem/62133579>
Comment 3 EWS 2020-04-21 17:14:08 PDT
Committed r260475: <https://trac.webkit.org/changeset/260475>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 397140 [details].
Comment 4 Ryan Haddad 2020-04-21 20:43:25 PDT
(In reply to EWS from comment #3)
> Committed r260475: <https://trac.webkit.org/changeset/260475>
The assert added with this change is causing macOS layout test and API test failures

ASSERTION FAILED: m_parameters.webPageProxyID
/Volumes/Data/slave/catalina-debug/build/Source/WebKit/NetworkProcess/NetworkLoad.cpp(66) : WebKit::NetworkLoad::NetworkLoad(WebKit::NetworkLoadClient &, WebCore::BlobRegistryImpl *, WebKit::NetworkLoadParameters &&, WebKit::NetworkSession &)

See: https://build.webkit.org/builders/Apple-Catalina-Debug-WK2-Tests/builds/3714
Comment 5 Ryan Haddad 2020-04-21 20:53:07 PDT
Reverted r260475 for reason:

New assert caused layout tests to exit early on iOS and macOS

Committed r260496: <https://trac.webkit.org/changeset/260496>
Comment 6 Diego Pino 2020-04-22 06:22:45 PDT
Also happening in WebKitGTK+.

STDERR: ASSERTION FAILED: m_parameters.webPageProxyID
STDERR: ../../Source/WebKit/NetworkProcess/NetworkLoad.cpp(66) : WebKit::NetworkLoad::NetworkLoad(WebKit::NetworkLoadClient&, WebCore::BlobRegistryImpl*, WebKit::NetworkLoadParameters&&, WebKit::NetworkSession&)

See: https://build.webkit.org/builders/GTK%20Linux%2064-bit%20Debug%20%28Tests%29/builds/6181
Comment 7 Chris Dumez 2020-04-22 07:53:30 PDT
Closing since patch that caused this was reverted.