Bug 203542 - Layout Test http/tests/resourceLoadStatistics/website-data-removal-for-site-navigated-to-with-link-decoration-database.html is a flaky failure
Summary: Layout Test http/tests/resourceLoadStatistics/website-data-removal-for-site-n...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: katherine_cheney
URL:
Keywords: InRadar
: 203576 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-28 16:27 PDT by katherine_cheney
Modified: 2019-10-29 12:29 PDT (History)
5 users (show)

See Also:


Attachments
Patch (2.00 KB, patch)
2019-10-28 17:07 PDT, katherine_cheney
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description katherine_cheney 2019-10-28 16:27:31 PDT
http/tests/resourceLoadStatistics/website-data-removal-for-site-navigated-to-with-link-decoration-database.html is failing almost every other run. 


flakiness dashboard: 
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=http%2Ftests%2FresourceLoadStatistics%2Fwebsite-data-removal-for-site-navigated-to-with-link-decoration-database.html

Currently unable to reproduce locally. 

Likely cause:
scheduleStatisticsProcessingRequestIfNecessary() is messing with the callback in website-data-removal-for-site-navigated-to-with-link-decoration-database.html The test calls processStatisticsAndDataRecords() manually when it is finished making changes.
Comment 1 Radar WebKit Bug Importer 2019-10-28 16:28:09 PDT
<rdar://problem/56689764>
Comment 2 katherine_cheney 2019-10-28 17:07:58 PDT
Created attachment 382140 [details]
Patch
Comment 3 John Wilander 2019-10-28 17:11:16 PDT
Comment on attachment 382140 [details]
Patch

LGTM
Comment 4 EWS 2019-10-28 18:12:20 PDT
Comment on attachment 382140 [details]
Patch

Rejecting attachment 382140 [details] from commit-queue.

Katherine_cheney@apple.com does not have committer permissions according to https://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/contributors.json.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in Tools/Scripts/webkitpy/common/config/contributors.json by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your committer rights.
Comment 5 katherine_cheney 2019-10-28 18:14:02 PDT
Guess I'm still too early...
Comment 6 EWS 2019-10-28 19:59:31 PDT
Comment on attachment 382140 [details]
Patch

Rejecting attachment 382140 [details] from commit-queue.

Katherine_cheney@apple.com does not have committer permissions according to https://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/contributors.json.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in Tools/Scripts/webkitpy/common/config/contributors.json by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your committer rights.
Comment 7 EWS 2019-10-29 11:16:43 PDT
Comment on attachment 382140 [details]
Patch

Rejecting attachment 382140 [details] from commit-queue.

Katherine_cheney@apple.com does not have committer permissions according to https://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/contributors.json.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in Tools/Scripts/webkitpy/common/config/contributors.json by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your committer rights.
Comment 8 Truitt Savell 2019-10-29 11:24:21 PDT
*** Bug 203576 has been marked as a duplicate of this bug. ***
Comment 9 WebKit Commit Bot 2019-10-29 12:29:40 PDT
Comment on attachment 382140 [details]
Patch

Clearing flags on attachment: 382140

Committed r251719: <https://trac.webkit.org/changeset/251719>
Comment 10 WebKit Commit Bot 2019-10-29 12:29:41 PDT
All reviewed patches have been landed.  Closing bug.