Bug 203469 - Add support for the Q unit
Summary: Add support for the Q unit
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL: https://drafts.csswg.org/css-values-4/#Q
Keywords: InRadar, WPTImpact
: 203321 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-27 09:46 PDT by Simon Fraser (smfr)
Modified: 2019-10-28 11:56 PDT (History)
11 users (show)

See Also:


Attachments
Patch (27.69 KB, patch)
2019-10-27 22:34 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews215 for win-future (13.63 MB, application/zip)
2019-10-28 00:42 PDT, EWS Watchlist
no flags Details
Patch (37.00 KB, patch)
2019-10-28 08:19 PDT, Simon Fraser (smfr)
koivisto: review+
ews-watchlist: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews214 for win-future (13.86 MB, application/zip)
2019-10-28 10:16 PDT, EWS Watchlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2019-10-27 09:46:47 PDT
https://drafts.csswg.org/css-values-4/#Q
Comment 1 Simon Fraser (smfr) 2019-10-27 22:25:05 PDT
*** Bug 203321 has been marked as a duplicate of this bug. ***
Comment 2 Simon Fraser (smfr) 2019-10-27 22:34:29 PDT
Created attachment 382044 [details]
Patch
Comment 3 Radar WebKit Bug Importer 2019-10-27 22:41:01 PDT
<rdar://problem/56660549>
Comment 4 EWS Watchlist 2019-10-28 00:42:56 PDT
Comment on attachment 382044 [details]
Patch

Attachment 382044 [details] did not pass win-ews (win):
Output: https://webkit-queues.webkit.org/results/13184514

New failing tests:
fast/dom/HTMLImageElement/sizes/image-sizes-w3c-4.html
fast/dom/HTMLImageElement/sizes/image-sizes-w3c-2.html
fast/dom/HTMLImageElement/sizes/image-sizes-invalids.html
fast/dom/HTMLImageElement/sizes/image-sizes-w3c-3.html
fast/dom/HTMLImageElement/sizes/image-sizes-w3c-1.html
Comment 5 EWS Watchlist 2019-10-28 00:42:59 PDT
Created attachment 382047 [details]
Archive of layout-test-results from ews215 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews215  Port: win-future  Platform: CYGWIN_NT-10.0-17763-3.0.5-338.x86_64-x86_64-64bit
Comment 6 Simon Fraser (smfr) 2019-10-28 08:19:11 PDT
Created attachment 382072 [details]
Patch
Comment 7 EWS Watchlist 2019-10-28 10:16:11 PDT
Comment on attachment 382072 [details]
Patch

Attachment 382072 [details] did not pass win-ews (win):
Output: https://webkit-queues.webkit.org/results/13185414

New failing tests:
fast/dom/HTMLImageElement/sizes/image-sizes-invalids.html
Comment 8 EWS Watchlist 2019-10-28 10:16:14 PDT
Created attachment 382079 [details]
Archive of layout-test-results from ews214 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews214  Port: win-future  Platform: CYGWIN_NT-10.0-17763-3.0.5-338.x86_64-x86_64-64bit
Comment 9 Simon Fraser (smfr) 2019-10-28 11:56:49 PDT
https://trac.webkit.org/r251662